Does anybody know what causes “missing file privileges”?

I’ve been looking for a solution to my missing file privileges problem for a long time, I think knowing what caused it can help me fix up my laptop.
Is this just some fussy thing about Windows 10?
If you don’t know what the hell im talking about, a while ago, I launched A Hat In Time to update it and got a missing file privileges error. I fixed the bug by removing and then reinstalling the game, but ever since, it’s haunted me with a deadly blue screen with a stop code: SYSTEM_SERVICE_EXCEPTION
I cannot get past the login screen. The most I can get to is 1: The legacy security options menu, and 2: Entering my password. But as soon as I hit enter with the right password, the blue screen strikes.

I don’t know about the cause but have you tried all of those yet?

https://support.steampowered.com/kb_article.php?ref=2274-IFLV-5334

He got the game running, just can’t get into Windows it sounds like. @Spydermann from your post in one of the forum games, it looks like you tried a repair to your Windows installation?

1 Like

Seems that uninstalling a hat in time might changed/corrupted something important in your OS.
Gotta make your computer fix that for you.

Solution 1

Id consider this solution an optional one until one of the other ones have been tried since updating a piece of software while it’s not working because parts of it might be corrupted could end up making things worse or be a complete waste of time when another possible solution undoes what the first one did.

Solution 2

You need to get back to the login screen, but instead of logging in you’re gonna need to press and hold down the shift key, then press the power button on the screen and then click on the restart button that pops up in the little box.

Now windows will reboot into a little menu that will allow you to boot into safe mode, i
Click on trouble shoot
Go into advanced options
Click on “show more options”
Select “startup settings”.
Then click on restart, now it will bring you to a screen that gives you the option to enter safemode by pressing f4.

Now that it’s booting in safemode you need to head into the login screen and log in with an account that has admin privileges, if your computer doesn’t crash now then you will be able to into your command prompt, if it still gives you a blue screen of death just skip the paragraph below.

Go into the search field and search “cmd” and open it as an administrator, then type in “chkdsk /f”.
type “Y” and press enter when it ask if you wanna schedule a check, then restart your computer to initiate the process.
Now your computer will begin scanning the OS for any corrupted or damaged files that it will need to repair, if you’re lucky this will fix the issue.

Solution 3

If attempting to boot in safemode results in a BSOD then you can do this fix instead, although first you wanna make sure your computer is turned off.
Get a bootable USB with a Windows 10 ISO file.
Connect the USB to your computer and turn it on.
Then while it’s turning on begin continuously pressing whatever button you need to press to access your BIOS.
Set your Boot Order to boot from the attached USB first.
Save settings and exit BIOS.

Now your computer will boot whatever files it finds on the USB, when it has loaded them and you are on the windows installation menu click on the little option in the corner called “repair your computer”.
Then press “troubleshoot” and click on “advanced options”, then select “startup repair”
Now your computer will attempt to scan for any damaged/corrupted system files and repair said files with the clean ones from the ISO file in your USB

2 Likes

All steps I would’ve advised as well. Been through it a few times yourself too? lol

I work in IT, currently in a position that has to fix broken PCs and sort out peoples computer problems.

As do I. I work at a small business, so my job goes beyond that of a computer tech sometimes, but that’s usually what I’m doing as well.

I actually have been using that little menu, I will begin trying all of the methods people are telling me to do, thank you for the methods.
Also, I noticed an option on the troubleshooting menu that boots me to the command prompt. I am in the process of starting my computer with safe mode, but if I get a blue screen, does entering “chkdsk /f” work in the troubleshooter
mode of command prompt?
Update: I tried it, as my luck prefers, didn’t happen to work. There’s another option in the menu that lets me enable safe mode + the command prompt. I’m doing it. Hopefully it works, I want to get that haunted television before it’s too late.

Yep, that’s all correct.

You may have to reinstall Windows. But try running a chkdsk from the troubleshooter command prompt

I tried it just a while ago, just doing chkdsk tells me there’s a bad file and tells me to use chkdsk /f. When I do, it says “This system is write-protected.”
Would reinstalling be the last thing to try?

No idea why your harddrive file system has been marked as read-only.
Anyway here’s a fix for that, if this fix doesn’t work then id urge you to attach your harddrive to another computer, set it to not boot on the disk you attached and then backup all the data from your disk that you don’t wanna lose to that computer.

Enter the command prompt again like you did last time to schedule chkdsk, instead this time you type “diskpart” and click on yes in the little confirmation box if such a thing pops up.
Then type in “list volume” to see all your attached harddrives and then find the number of the harddrive you’re trying to fix.
Type “select volume x” (x being the volume number you were looking for)
Then type “attributes disk clear readonly”, that will remove the write protection from your harddrive.

Then type “exit” to exit the disk partition window, reopen the normal command prompt and type “chkdsk /f” and do the usual schedule for next restart and then restart the pc, now it should do the checking process again but this time it will be able to fix the errors on the disk.

You can also check the side of your harddrive physically to make sure the manufacturer hasn’t put a physical component on that enables write protection, if they have you will need to switch that thing off.

1 Like

I’ve never actually seen this on a hard drive, do they really still do this?
EDIT: Actually I don’t think that would work considering the switch wouldn’t be able to differentiate between windows and the user. So windows would never be able to change files, and you’d never be able to download a game or anything.

Are the first two blocks of text separate solutions? I’d like to get a clarification for that so that I can make sure doing “diskpart” won’t damage my computer in any way.
Edit: I forgot to mention that I’d like to try diskpart first.

The very first paragraph just says that if the following solution in the second paragraph doesn’t work then id recommend you think about if you should start copying all the data you don’t wanna lose to another computer and then reinstall windows on the hard drive you were trying to run chkdsk on.

Since there really isn’t many other solutions left other than using the windows USB to do a startup repair

Paragraph Indicator:

Edit: Forgot to mention you might also wanna try and check if its the disk itself that is write protected by doing “list disk” in the diskpart program and then selecting the disk itself with “select disk #”

1 Like

system_service_exception is a different error. However, I can tell you about missing file privileges issue.

i figured it out, but it didn’t have anything to do with windows 10 for me. what i had to do was go to steam in file explorer and delete everything in the file except for the steam.exe launcher, commonapps, and user and it worked perfectly.

Check out this link. and tell me if it helps.