Crash On Startup, No Error Message

Tried looking through the forums and trying everything I could see that people suggested in previous posts, as well as tried asking in the Discord, but no luck. I’ve got a new PC and for some reason this one is not letting me play the game, every time I boot up the game it either goes to a black screen or the first loading screen and immediately exits back to desktop with no error message or anything that could possibly help me figure out what the issue is. Also this only happens with this specific game.


  • Processor: 11th Gen Intel(R) Core™ i7-11700KF @ 3.60GHz
  • GPU: Nvidia Geforce RTX 3080
  • Ram - 32 GB
  • OS: Windows 10
  • PSU: 1000w
    (Not sure what else I would need to list if anything, LMK)

Attempted fixes:

  • Uninstall/reinstall
  • Verify integrity of game cache
  • Remove all tower unite files from computer then reinstall
  • Uninstall and reinstall graphics card drivers
  • Launching it in -windowed
  • Launching it in -nosound
  • Launching in DirectX10,
  • Reseated ram and gpu
  • Replace ram
  • Reinstalled windows
  • Installed onto my harddrive instead of my SSD
  • Launched in compatibility mode as windows 7 and 8
  • Launch as administrator
  • Launch the exe straight from the tower unite folder in the steam folders

Please help :frowning:


Not sure if these will change anything, but maybe try deleting/renaming/moving these folders.

If it’s something going wonky in your settings:

And idk what’d deleting this folder would do, but it is associated with the game (condo saves and workshop upload thumbnails), so maybe take it along for the ride when completely uninstalling.
C:\Program Files (x86)\Steam\userdata\[steamID32]\394690 (assuming Steam is in default install location)

ALSO- check if there are any crash logs in %localappdata%\Tower\Saved\Crashes just in case. You said there’s no error, but idk, there might be a chance there’s a crash log being saved and it’s not showing the crash reporter.

1 Like

I’m having the same issue, I checked the crash log and it doesn’t really say anything.




I’m having the same exact issues as above. Can’t get past “loading” without it exiting to desktop.
I recently upgraded my entire PC (everything is brand new) and have wiped windows since new parts. There’s no error logs at all other than the same one @Doctordaki posted above.

Verifying the game files hasn’t solved anything/a clean install of Tower Unite sadly hasn’t solved anything neither.

CPU - 11th Gen Intel(R) Core™ i9-11900K @ 3.50GHz
RAM - Corsair Vengeance RGB Pro 16GB (X2)
Motherboard- Gigabyte Z590 Gaming X
GPU- Nvidia GeForce 3060 RTX MSI
The game is also on an M.2 drive.

Everyone on this thread has new Windows installs? Did everyone make sure they are up to date with their drivers?

The only reason I could think the game being stuck at loading is the download from Steam somehow got corrupted.

Is it me, or do all of these problematic computers have 11th gen Intel Core processors?


I noticed this too.

@Doctordaki and @Kingston_Waechter, could you specify your CPU? It may help us narrow the issue down.


I can’t speak for everyone, but yeah I did a fresh install of Windows as well as made sure all of my drivers were updated. As well as removing and reinstalling my graphics drivers.

Yes, drivers are up to date as well. This wasn’t happening until I completely upgraded the PC. I can’t seem to figure out what is going wrong here though. I thought it was Unreal Engine itself that was conflicting somehow at first but ARK as example starts up fine. Unless TU runs on another build that I seemed to have missed.

1 Like

Unsure what version Ark uses but TU does run on an older build of the engine.

EDIT: You stalking me, Kingston? :stuck_out_tongue_winking_eye:

EDIT2: You liked this post like a freakin nanosecond after I posted it. lol

Intel® Core™ Processor i7-11700KF 8/16 3.60GHz



I posted a thread about having this issue back in April 16. I havn’t gotten any further response about it either (first reply didn’t work). I suspected at first that it’s just 11th gen cpus having this issue, since it was the only component I changed in my build.

1 Like

Its been a few days. Would at least like confirmation that the issue is getting looked into. Really want to play the game with my wife now that we both have gaming PCs

We are looking into it, but we don’t work on weekends. We’ve been trying to figure out the cause.

On Monday I’ll be setting up a test branch of the game to see if that resolves it for everyone here. I’ll give info on how to switch to the branch.


Thank you very much for the update. I assumed you guys were working on something, just wanted to make sure.

1 Like

Thank you! I was about to suggest on another post I saw that it was possible 11th Gen causing issues with the game. I’ll be sure to test it when it does go live

I haven’t even played this game before but I’m having same issues in some other games.
Built a new PC with i9-11900k and had to used my old 2070.

I tried to play A Way Out with a friend but the game crashes without any error or log after about 2 minutes. Doesn’t matter if I start the lobby or just stay in the menu.

Same thing with Breathedge. Bought it few days ago and wasn’t able to play it because exactly the same thing happens.

All of these games including TU use Unreal Engine 4 so that might be related.
Thought this info might help you resolve it and maybe hopefully help make a global fix or something like that.