Game won't launch after CPU upgrade from 9th gen to 11th gen

Upgraded from i5 9600K to i9 11900K. Absolutely nothing else in the computer changed.

Game used to boot with i5 9600K.

Game doesn’t boot anymore after the upgrade. It doesn’t even get past the loading screen to the main menu. I suspect that the game probably doesn’t support 11th gen intel cpus or hasn’t been updated to yet?

The details of what happens is that I boot up the game. DX10/DX11 were both tried, same results. Game just goes to the loading screen before the main menu. Spinner barely moves then freezes. Game then either freezes for a few seconds and closes itself, or just immediately closes itself.

No crash reports or dumps were made. Reinstalling the game and verifying files did not fix it. Removing cache folders did not fix it. Removing configs did not fix it. Drivers are all up to date. Windows is also up to date. Closest thing I can get to a log/report/dump is just “-log -verbose” in launch options. CMD opens but it stays blank.

This is all I see before the game closes itself.

CPU: i5 9600K → i9 11900K
GPU: Zotac RTX 2060S Mini (V: 466.11, 04/14/2021)


Given that the only change to anything is the CPU and that it has integrated graphics, the cause is most likely that the pc is trying to run the game using that instead of a dedicated GPU.

Since you got a GPU from nvidia i would recommend heading into the geforce control panel and try and set tower unite to use the dedicated GPU to run the game.

If that doesn’t work you can also try downloading and installing the relevant drivers for your new CPU

Running the igfx_win10_100.9466.exe installer from the site and igxpin.exe from the zip gives me the same error. (They both asked for admin)

D&S webapp tells me everything’s up to date.

Ontop of that, since nothing’s plugged into my iGPU port, iGPU isn’t detected by the computer.


1 Like