Exceeding model vertices... by a lot

#1

Hello, I’ve been working on a model recently and I’ve been trying to import it to TU.
The model has 29k vertices, but when imported to TU, it shows that it has 260K vertices.
After some searching around I found out that it’s just how model importing works in TU, and tried decimating the model so that I can hopefully reduce the vertices shown in TU.
After decimating to the lowest I could before the model breaking completely, (9k verts in blender), in TU it shows that it has 100k vertices…
I didn’t find any other way of reducing vertices. Is my model just unable to be imported to the game for good?
EDIT (pics):
(Decimated & removed doubles)
1
20190428210209_1

0 Likes

#2

not an expert on this kinda stuff, but this post may help ? More vertices reported in TU than Blender

0 Likes

#3

Yeah, I already tried to do what was described in that post, but it still doesn’t get me under 30k vertices

0 Likes

#4

Have you tried removing doubles? This will take out any overlapping vertices and merge them together, it’s quite useful.

0 Likes

#5

Still no luck
1
20190428210209_1

0 Likes

#6

So… After a bit of messing around I managed to go a bit below the limit (29.5k vertices, while the model is 5k vertices in blender). Here is some tips I could give that helped me reduce the vertice count.
-Uncheck the “triangulate” box when exporting the collada
-Remove doubles
-Selecting all faces of the model and pressing alt-j to convert tris to quads
-And decimating the cr*p out of your model
Although it’s really unfortunate that you have to degrade your model (in my case, by a lot) to get it in TU, but at the time I am typing this, it’s how the model importer works, hopefully it will be improved in the future. The last comment I’d like to make is that… Apparently TU’s model importer really does not like tails, or any parts with jagged edges, (a “tail” with 600 vertices showed up with 8k in TU), so try to smooth it out as much as you can. That’s all I have to say, toodles.

0 Likes