[] No Plaza Servers Appearing

I tried to get help on Steam but nobody cares apparently so I made an account just to ask for help here.


I have used the trick of the “View>Servers” on steam thing, but it doesn’t connect me! It just sends me back to the title screen! So, can I get some help?

Is your game definitely up to date? Have you tried restarting your game?

Yes and yes.

I have restarted the game multiple times since this started yesterday, and the game has “” in the corner.

1 Like

I get this issue often too, I usually just keep refreshing, and after the 4th or 5th time it usually works

Just tried to do that. Nothing. I refreshed 15 times and nothing.

Unfortunately I can’t think of anything else that could help, Good luck though!

Also before I forget: I tried going to the lobby via Condo. Nope. (Though I think that was turned off considering what i’ve heard)

1 Like

What country do you live in? I’ve heard of issues with Steam not wanting to show servers outside of your region, so maybe you just don’t live near any servers.

US of A. The plaza servers worked fine when I first played, Second time the Official server disappeared from the list, and then the 6th time (Right after the update) no servers at all.

Come on, any other ideas? I’m unable to access about half of the entire game!

Are you able to connect to other servers? I know that Norton likes to block TU from accessing the internet, so an antivirus software might be the culprit.

Yes! I can join Minigolf, Ball Race, Planet Panic, AND Virus! Only the plaza servers don’t show up.

Still need help. (Man, maybe they should’ve added an IP Entering thing on the list, then maybe i could actually do things.)

I still do

EDIT: I just realized I can’t buy ANYTHING. (Tried buying for character, “Transaction Failed”)

Having the same problem here. I tried reinstalling the game but it did not work

I found a fix! For some reason the firewall was blocking nothing but the plaza servers. Odd, right?

If it was the AV firewall, nothing is odd :stuck_out_tongue:

1 Like

Oh my god I could kiss you.

Turns out my Norton had a program breaking error and that was preventing me from getting in



same issue.

  • I’ve checked that steam isnt running multiple versions of Tower Unite.
  • I’ve tried refreshing multiple times
  • I’ve tried entering via condo
  • I’ve tried reinstalling the game
  • I’ve tried giving exclusion to tower unite via my anti virus (kaspersky)

Is your name Player? Is your build name 0? If it’s like that, you have 2 steam.exes/tower.exes open, end one of those tasks. They will be in the processes tab of Task Manager.