[] No Plaza Servers Appearing

Not sure what you mean by my name being Player. where would I look for this?

Updated the build now to 0, still doesn’t load the Plaza servers. And also tried verifying game cache to no avail.

Task manager is definitely only showing one process of Tower unite.However before this happened I would often quit out of Tower unite and it would be running two versions of the game. I seem to have stopped with that issue for a moment.

Have you checked the Steam ports? They may not be opened for you, which can cause issues reaching the master server browser.

Here is a list of the ports: https://support.steampowered.com/kb_article.php?ref=8571-GLVN-8711

unfortunately this didn’t help either.

You might have two tower.exes or steam.exes running. If that’s the case, close all of them in the processes tab of Task Manager and load up steam and Tower Unite again. It should work after that.

I mentioned before that there isn’t in the previous reply. thanks for trying to help anyway.

Checked the Windows Firewall then? Try turning it off just to see if it makes any difference.

Also make sure Steam is downloading the latest update to the game, so they are not left in a queue.

I’ve tried both of these, thanks - still hasn’t helped.

Tried turning on/off UPnP on your router?

still nothing :slight_smile:

All I can suggest then in that case is to get a different router, something must be wrong if all the steps you have taken were done correctly.

Would be nice if any PixelTail Games developer have anything to share regarding this?