Unable to join any Plaza at all

For some reason, my game suddenly won’t let me connect to any Plaza at all. All official Plazas have no ping and have “–” as their player count. I’ve tried reinstalling the game, restarting my computer, verifying the integrity of my game files, and messing with my antivirus, but none of that has worked so far. https://imgur.com/a/GSqbWJQ

The specs of my computer are:

  • Ryzen 5 3600
  • Radeon RX 580
  • GIGABYTE B450M DS3H WIFI Motherboard
    16GB of memory is installed on my system.
1 Like

Have you tried actually hitting the join button? It’s possible that it’s just the server list bugging out and you’ll still be able to connect to the server.

I have tried hitting the join button multiple times but it just ends up loading for a very long time and then it just kicks me back to the menu screen with no error code.

A number of my friends have this issue, too. You’re only able to join plazas that display the playercount properly, and we haven’t been able to find a fix or workaround sadly.

Sometimes 1 or 2 servers will show playercounts though, but they’re usually in the wrong region :confused:

Ah, I see. I’ll wait until there’s hopefully a fix or workaround found then. Thank you!