Tower Unite doesn't start

I have Intel Core i5 1035G1 8GB 1TB + 256 GB SSD MX330. I see this and then nothing happens.

Please try re-verifying the game cache.

I tried again but it didn’t work.

Try updating your graphics drivers and try again. If this doesn’t work, it could be that your laptop doesn’t meet the requirements to successfully launch the game, if this is your first launch on that computer…

Based on the language of your operating system, which i’m assuming is Turkish, the appearance which seems to be Windows 10, and since you have 8 GB of RAM, it would need to be 64- bit, and since the MX330 is a laptop graphics chip, you can find your update here.

If this is not the case, please consult your laptop manufacturer’s website.

3 Likes

Taskbar looks more like Win 8 to me

Windows 8 did not had 10th Gen Intel CPU’s support like the one he’s using.

3 Likes

The CPU was released in the 3rd quarter of 2019, so its extremely unlikely it would be Windows 8.

^

2 Likes

Yeah, you right. Just compared the taskbar in the image with mine and its identical except that I have a search box instead of just an icon. Apparently I forgot what my own taskbar looked like. lol

I have the same problem with my brand new Asus TUF Dash F15.

The spec is

  • i7 11370H
  • 16 GB Ram
  • RTX 3060 Laptop
  • Windows 10 Home

I have setted the game to use dedicate graphic card.

The tried verify game file via steam, reinstall game and nothing works.
The moment I launch the game it loaded into the first screen (Loading Main…) then close itself.
I tried both DX11 and DX10 mode both give the same result.

Every crash file report contains this information

[CrashReportClient]
bHideLogFilesOption=false
bIsAllowedToCloseWithoutSending=true
CrashConfigPurgeDays=2

Could you please help me with this problem?

Have you tried updating the graphics drivers? Even if your laptop is “new” it could have been sitting for a while beforehand.
Also, sometimes the drivers that come bundled with new computers are only ones that were released by the manufacturer and can be quite outdated at times.

If you still continue to receive this issue afterwards, try doing a speedtest on your internet connection as this game relies heavily on a stable and fast connection (especially with workshop models).

Try closing any non-essential background applications, and make sure you run Windows Update to make sure you are up to date in that aspect as well.

Thank you for you suggestion.

I have updated my driver and I have 700 mbps/200 mbps internet connection.
Also I restart the laptop and make sure nothing unnecessary program is running then start a game.

Sadly, it still won’t load pass the first loading screen and crashed again. The problem does not happen with my 5 years old desktop tho.