Public Condo not Appearing on Condo List

As of a couple of nights ago, I’ve had my Default Condo open to the public but no one would join. I then had my friends stream their Visit Condos menu, only to find my condo isn’t actually appearing on the menu to join. My friends can join via steam when it is set to both public and friends only.
The last person to join my condo when public was on the 26th of June, so I don’t know what would have changed during that time. I’ve tried to open other condos but yield the same result. I’ve restarted, validated files and changed VPN but again to no result.
I just want people to see my Catacombs man : (


Server naming bans recently got changed ( to also make it so your condo doesn’t show up in the plaza browser. You can appeal bans here: How To Appeal Bans


There is a bug that happens still here, i’ve had it where i’d host for a long time and turns out im not on the list or sometimes i’d be on the list then at some point i’d go off the list but it happens very rarly. It might have something to do with steam.

1 Like