Missing Textures on .dae file

Disclaimer: I’ve read all the documentation and watched the videos Pixeltail has provided for Workshop furniture but haven’t found a solution. 3D modeling is new territory for me so please excuse any ignorance on my part.

I’m trying to make a crude object just to test things out and make sure I can get through the process, however I have hit a wall trying to get my textures to import with my model. I’m trying to export a .dae object, but have also tried .fbx which had the same issue.

Here is the model.

I have the object UV unwrapped (Even though its a little sloppy) and am applying an image texture to the material.

Here are my Material and Texture properties, I’ve tried playing with both the materials and texture properties a lot.

In Blender everything seems fine. Reading the “Troubleshooting” section of the Workshop site states for .dae models:
If you use .DAE, MAKE SURE YOU CHECK “Include UV Textures” and “Include Material Textures” in the export settings.
If you use .DAE, you can view the DAE in notepad to see where the texture files are pointing to.

However, I’m not sure if this is because I’m using Blender 2.79, but I don’t have the option to choose both Include UV Textures AND Include Material Options. My options look like this:

When checking my .dae object in a text editor there seems to be information saved for the material, but none for the texture. I’d imagine this would be under image library, but my .dae has nothing saved under this and I can’t find out how to change that. So I don’t believe the .dae object is actually pointing to my texture image and this could be my issue that I can’t seem to resolve.

After many failed attempts to import, this is what I get every time.

I knew there would be a learning curve to all this and am just reaching out to see if anyone can recognize any glaring flaws I’ve made or if someone knows the solution to my issue. Thanks for taking your time to read!

EDIT: Forgot to mention some of the parts where I’m choosing the texture image in the blender UI names renames my “maskmat.png” to “maskmat.png.001” and I read somewhere this was an issue for someone else causing a loss in texture. I can’t seem to find out why “.001” is being appended to my texture image and when I attempt to remove it in one field it adds it to another. This may be irrelevant but I’d figure I’d mention it just in case.

If I had to make a guess as to the issue, it’d your use of nodes.

I had issues importing textures when the update first dropped and it turned out to be a lack of support for Cycles nodes. You’ll need to change back to Blender Render and create new none-node materials with textures to import properly.


Sinera, you genius! Thank you! Upon troubleshooting I’ve read that I needed to switch to Blender Render but never actually added the material/texture under that render setting. I’ve made progress but still have one question.

So as you can see I actually have my basic colors applied now, but I’m still getting a “MISSING TEXTURES” prompt. I’ll play with it more to see if I can remedy this just not sure why this is occurring still when its stating the texture file name and my colors are actually being applied. Maybe its because my model is sloppy. I noticed I had a face missing around the inside of the mouth during this.

Thanks again! You don’t know how long I was playing with this trying to just get to this point! Super Quick response too!


Thank you Sinera! I had to expore with UV Texture and not Material.


I know that feeling well and I’m glad to see it all worked out :blush:
As a final tip, make sure your imported items are facing you with the ruler on the left so they face the right direction when rotation is reset or a player picks it up:


Forward in Blender is actually the -X axis when exporting, so make sure your stuff faces that way when you’re done. Keep up the good work!


Good tip, thank you! Yea I was so caught up with the texture issue I didn’t double check my origin and now its kind of offset. This has been a huge learning experience for me haha.

I have the same problem, library images this empty, how could you solve it?