GMTower 10th Anniversary Release Announcement

Hey everyone,

This is the final update on the current state of GMod Tower: Reunion, which was previously discussed here (Reunion):

The GMod Tower: Reunion server is now online and available to play!

As has been established in our previous posts, GMod Tower is being presented as it was before 2015, featuring Lobby 1. There will be no additional maps, bug fixes, or other developments on GMod Tower besides adjustments that will allow the game to run properly as it was. Tower Unite is our focus and all of our development efforts will be spent there.

There are a few remaining minor issues with GMod Tower that we know about. We spent time and effort trying to resolve these issues, but we ultimately couldn’t afford to spend more time on it (as we already put in a full month and half of paid development time on it, and we need to work on Tower Unite). These minor issues are:

  • Blocking system does not work properly and was ultimately disabled
  • Source Karts: Kart color does not work
  • Minigolf: HIO rocket doesn’t launch the ball
  • NPC eyes are always closed
  • Pool tubes have a visual issue when entering them
  • Theater idlescreen doesn’t loop properly
  • Now playing message doesn’t work for theater due to theater media player changes

Overall, there were 104 bugs (several major issues) and 4 major refactors (such as redoing the networking engine) that had to be done to get it all working properly. A lot of time and care was put into ensuring each feature worked as it was in Lobby 1.

We have more information on how you can join the server and more on: https://www.gmtower.org/reunion/play/

Thank you for your patience,

PixelTail Games

39 Likes

Even though I’m still not sure if this time wouldn’t have been spent better just staying on TU development:

:clap:

10 Likes

We know GMod Tower means a lot to people for all sorts of reasons, and to celebrate such a big time in PixelTail’s history we thought it’d be a good time to bring GMod Tower back. It took longer than expected but now it’s full steam ahead with Tower Unite!

Keep in mind that not all devs spent time on GMod Tower - a few people worked on GMod Tower while some devs and our artists continued to work on things like the Arcade.

7 Likes

i was going to sleep
nvm then guess i will do that later

2 Likes

No more sleep, it’s time to play GMod Tower again.

1 Like

it is midnight and im dying inside but this is more important

1 Like

Life is meaningful again

2 Likes

i was going to sleep
nvm then guess i will do that later

2 Likes

Me entering Area 51 with Tower Unite
Me leaving Area 51 with GMod Tower
The Area 51 guards questioning why they have to kill me

4 Likes

The one day I’m out for the night. God damn it.

1 Like

Unstable, Money reset to 0 after first crash and my player model disappeared sometime too.

Stuff’s unstable at the moment, but hopefully the dev team can iron out the bugs ASAP!

All of the major issues causing instability during the first few hours of the launch have been addressed.

1 Like

Linux Users
[edit]
After some more testing, I can’t get gamemodes to work properly, most of the time it crashes, and too many CTD’s in general. Instead use Proton. Set Garrysmod to run in Proton 4.11, and opt into the [dev] build, this works flawlessly so far. I think the native Linux client is too unstable.

Some Linux information

I don’t really know where I could put this to help those who might need it(or the developers to help fix it), however to run this on Linux(native client) there’s a step that needs to be done;

The Linux version of Garrysmod doesn’t import mods that have capitals, the main folder won’t be imported, so renaming the addon to “gmt” or something will import it.

However the mod also contains other files and some with capitals, and so you’ll end up with a few missing textures etc. To fix that what I did was convert ALL files/folders to lowercase(which I assume is how they’re named in the Lua code). On Windows there’s no conflict between capitalisation but there is for Linux file systems, this seems to be the cause because afterwards the last few textures loaded.

To convert all the files to lowercase you can execute a command using “rename” (sudo apt-get install rename)
In your terminal navigate to the addons folder then run;
find gmt -depth | xargs -n 1 rename -v 's/(.*)\/([^\/]*)/$1\/\L$2/' {} \;
(“gmt” being the renamed “GMTReunion” folder)

This will convert all files/folders in the “gmt” directory and subdirectories to lowercase.

So far the majority of things are working, since changing to lowercase I’ve had no more missing textures, although I’m still testing it.
I still do get random crashes to desktop though, and still investigating that.

5 Likes

Nostalgia intensifies…

I’m getting the error when connecting that ‘gmt_build0s2b.bsp’ is missing, however it’s with the other maps within the folder that was extracted. Has anyone else had this issue? Sorry if I’m being a dunce, I’m not that savvy with this sort of stuff.
edit - Seem to have got it working, thought not sure exactly what I did, just started messing about with the files.
edit numero dos - I have missing textures in the lobby, can anyone tell me where I need to get these? I’ve got all the games on the list and have them installed, as well as the folder.


I had the “missing_map” problem, that just means it can’t see the reunion folder in addons (So it can be caused by a lot of things).

I’m no expert, but the things you’re missing seem to be stuff included in the Reunion/workshop addons?

So, I’d say: Make sure you’re subscribed to the workshop collection, make sure you have the full reunion addon (As a folder) in your addons folder, and click the game controller icon on the GMod title/pause screen to check off all the game content.

Personally, what fixed the “missing_map” problem for me (Which I know you already fixed, but maybe this’ll help), was getting rid of an excess folder. By that I mean: my file path for the reunion addon was: garrysmod/addons/GMT Reunion/GMT Reunion/[content folders], so I changed it to: garrysmods/addons/GMT Reunion/[content folders].

I’m still lost at the missing textures, I’ve got all the addons, I’ve got all the games, I’ve checked all the boxes, I’ve downloaded the folder and have moved the files about and cleared them and re-downloaded them and started the game over and over and I haven’t had these textures show up, including the skybox, so it has to be something to do with the folder, but I can’t figure out what. When I figured out that one of the things being affected was the skybox, I did a fresh download of everything, restarted everything and then went in again, only to find that the textures were still missing. This is driving me slightly insane.

Issues with the addons folder are tough, because they’re different for everyone. Mine was with a duplicate folder, somebody else in the Discord was using the wrong addons folder on a different drive, it could be anything.

Though the fact that the game is running is interesting, for some reason parts of the folder aren’t getting read. Sorry I couldn’t be of help, it would be useful if there was sort of “debug” log that would say exactly what textures weren’t being accessed properly, but I’m not a GMod nerd, so my advice ends here. Good luck!

The problem is with the map itself if anyone can help identify with that, the server is fine.