Game runs fine... except when I'm host


#1

I purchased the game nearly 4 days ago and it runs perfectly as one would expect everywhere else, I get 80-100+ fps in the lobby, games, and other user’s condos. However, whenever I try to go to my own personal condo I get less than 10 fps and it is practically unplayable. (Even on flat grass with no objects)

I have asked many other users to see if this is a common problem and nobody has ever experienced it before. I have tried so far with no success:
• Lowering graphics settings as much as possible (still lags, even then)
• Disabling, enabling vsync (I’ve pretty much tried every graphics setting)
• Running DX10 version
• Updating graphics drivers to latest version
• Completely reinstalling graphics drivers

I would say I have a decent computer though not the best, it can and should be able to run a game like this perfectly fine, and it does except for my condo. Here are the specs. https://valid.x86.fr/00uk0p (cpu-z link)

Any insight or help would be greatly appreciated because condos are one of the aspects that I loved
most in gmt.

*EDIT:
I forgot to mention in my original submission: When I am in my condo it’s not like it is maxing out my CPU and GPU and struggling to render. It is only using 20-30% GPU and CPU power, so it is definitely not a matter of my components being inadequate, though maybe a strange architecture quirk or something.

**EDIT II:
I have discovered that this happens when I host games as well, so the problem is not my condo it is everything that I host. I still don’t know what could be causing this though, because I have a quite good internet. I will research other people experiencing lag involving P2P as it constantly says p2p connecting in the games that I host.

New Stuff I’ve tried (And still hasn’t worked):
• Removing all VPNs
• Flushing DNS
• Turning off Windows Firewall


#2

This is… strange.

I seem to have the opposite problem to you, but I’ve just chalked it up to a crummy computer.


#3

I wonder if the Tower Unite dev’s have any info on the ports it uses. Maybe you could forward those ports on your router. That’s helped me with P2P lag in many other games


#4

Worth a shot? Anything would help, I’ve got all this money saved for condo stuffs but nothing has worked yet


#5

Can you get into your condo at all, if you select private?

And you’re sure you’ve completely disabled windows firewall? Because I know upon first launch, windows will ask you if you want to allow TU. You have to click yes on that. But if you’ve got it completely disabled, it shouldn’t interfere at all.

These are the ports for the dedicated server, maybe P2P uses the same? Not 100% sure.

7777-7780 UDP
3478 UDP
4379-4380 UDP

I’ll keep digging

let me know when you’ve tried those, and if it worked. If you don’t know how to port forward on your router, search it up lol. You can find how to’s all over the internet, it’s not too hard to do.


#6

I can get into my condo, but even when it’s in private it lags. I am thinking this is because p2p is used to sync up the door and other stuff with plazas. I am sure that firewall was disabled when I tried that to no avail.

In port forwarding, I have discovered something interesting… my router has 2 ips assigned to my computer. I have a feeling that may seriously screw some things up so I’m going to try to do some unassigning and resetting and see if that fixes anything.


#7

YES!!!
THAT DID IT!!!

oh my god thank you!!! if it were not for you having said that i would have never found that conflict that was causing p2p to explode.

so if anybody else is having this same problem - CHECK YOUR BLOODY ROUTER CONFIGURATION!!!


#8

Oh yeah, two IP’s will do it. Do you have wifi and Ethernet connected to your computer, or was there just a stuck IP?


#9

I port forward frequently so i had the address 254 reserved for my pc so it wouldn’t change and this has never been a problem before but apparently something happened either on my computer or with the router that caused my pc to take the regular ip it would have been assigned AND the reserved one which caused p2p to shite itself.


#10

ah, I’ve had that happen before. Luckily my router I’ve had for a few years now port forwards based on computer name/mac address. So it’s almost like having a DNS service built into your router. It’s nice because even if the IP changes, everything still works. Although the IP’s rarely change.