Game freezes at startup (as it has been for the last year)


#1

I have been waiting 1 year for a fix but each time the game
never starts, It just shows the Pixeltail games logo and freezes.
I have tryed waiting for the freeze to end but after an hour or 2 the game shuts down. I need help! I have tried contacting Pixeltail games and uninstalling and reinstalling as well as everything else.


#2

What are your computer specs?


#3

If you got DirectX installed you can easily find your specs with the dxdiag program which you can find by searching for “dxdiag” on your computer.

Otherwise you can search for “Device manager” in the search field and find them there-


#4

These are my specs,

Operating System: Windows 10 Home 64-bit (10.0, Build 15063) (15063.rs2_release.170317-1834)
Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: To be filled by O.E.M.
BIOS: F2
Processor: Intel® Core™ i7-6700 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
Memory: 16384MB RAM
Available OS Memory: 16336MB RAM
Page File: 4422MB used, 21323MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.15063.0000 64bit Unicode

Thanks for replying by the way


#5

Anyone still here or am i screwed…


#6

Sorry, I have been out of the office.

What is your GPU? It doesn’t seem to be posted on your spec list.


#7

To find your graphics card:
If on windows:

  1. Go into your search field.
  2. Type in “Device Manager”
  3. Click on the result and let the program load.
  4. Find the area called “Display Adapters” and click on the little arrow to expand it.
  5. Write what the graphics card is called in a reply to this thread. (For example: AMD Radeon ™ R7 360 Series)

If on mac:
Sorry but i honestly have no idea.


#8

NVIDIA GeForce GTX 970

Also if it helps, my game stopped working some time after the monorail was added.


#9

Have you tried updating your drivers (also make sure not to use any beta drivers)?


#10

Im not too good with this type of thing but il see what i can do. Its just strange that all my other games work.


#11

You mention other games work, have you tried other Unreal Engine 4 games? My hunch is your graphics drivers need to be updated for Unreal 4.


#12

Decided to try and find the drivers he would need to download if that was the cause of the problem.
https://www.geforce.com/drivers/results/83080

If downloading the update doesnt work you can try and searching for other updates here:
https://www.geforce.com/drivers


#13

Ok, i installed the update. So now do i just reinstall Tower Unite?


#14

No the update was for your graphics card, Tower unite wont need to be reinstalled for that, although id say you can try and make steam check the game cache just to be sure.


#15

To quote Isaac Kleiner:
Well, did it work?


#16

Still trying


#17

It didn’t work…


#18

The only thing i can think of that we could try would be to try and boot up tower unite and then check your event viewer to see if it can give us more info.

So type in “Event Viewer” in the search field and click on the result.
Then id say try and look in the administrative events window and see if there is a entry for Tower Unite there.
If not then im completely out of ideas for the time being.


#19

Nope, there is nothing… Ether way il keep looking into it, oh and thanks for the help


#20

Try the “application and service” option, it holds the logs for your program in general as compared to the administrative logs that holds information regarding the start up of applications and systems.