D3D device lost

Yesterday I got this error twice. Now it happens every time I open TU and try to start a game of Zombie Massacre. Please advise.

Windows 10
RX 460 (2GB)
core i5 6600k


this time I got a different error:

The D3D device issue is a pretty common problem in the unreal engine that epic games haven’t been able to completely fix yet since it can be caused both by hardware or software.

This version of the D3D problem seems most likely to have been caused by the workload on your gpu:

There are some possible fixes to this, some of them are in the two links i posted and another one i ripped from the steam forums.

Steam forums solution:
  • Go to the this link: https://msdn.microsoft.com/en-us/library/windows/hardware/ff569918(v=vs.85).aspx
  • There you will find a section called TdrDelay it gives you all the information you need to create a registry key that will change the delay time
  • To open your registry open your start menu and type “run” once the window is open type “regedit” and hit OK
  • Now you should have Registry Editor open this is where you will use the info at the website I just linked.
  • First navigate the key path HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\GraphicsDrivers
  • Right click on GraphicsDrivers and go to new> DWORD (32 bit) value
  • You will see a new key appear make sure to name it “TdrDelay”
  • Right click it and select “modify”
  • Under Value data enter 10 (this is the number of seconds to delay) make sure you have Decimal selected as the base
  • Hit okay and restart your system

Bear in mind that changing carelessly registry information is not recommended since it can cause other issues if you change something you shouldn’t, so be sure you know what it is you have to change and how it has to be changed

As for the GameThread timeout, your graphics card wasn’t able to keep up when it came to rendering, which is probably why you got a D3D device error.

To this the best solution would be to reduce some graphical settings to lessen the workload for the gpu:
Reduce texture quality to reduce the rendering workload and VRAM usage down to below what the card has.
Since your card only has 2GB VRAM the highest your card can properly handle would be High.

Enable fps cap to make a limit on how many frames the graphics card will have to render.
Enable vsync to force the graphics card to only keep as many frames as your monitor can handle, also reduces image tearing if your monitor isn’t powerful enough to keep up with the amount of frames it has to display.

And since the issue happens on zombie massacre you should also turn off decals and gun flash effects, maybe also reduce effects quality and turn off high quality shaders.


So changing from my main monitor (19201080, hdmi) to my secondary (1152872, dvi) took me from 95+ to ~30% gpu load, all other settings being the same. I honesty did not expect the resolution change to make that massive a difference. What was confusing was that the game ran fine for 2 days (with the GPU maxed) before these problems arose. Thanks, Heavy. It seems I really need a new video card

1 Like

Not to butt in here or anything, but if it was working fine earlier and it’s not now, you might want to see how hot your GPU is running. Check to see if all the fans are spinning when they’re supposed to, and maybe take the side panel off your case to see if that helps heat flow. It may not actually be an issue, but that’s sorta what it smells like to me, who constantly has heat flow problems :slight_smile:

1 Like