Cant load into servers?

Hi i cant load into servers?

ill be able to get past the first loading screen but as soon as loading plaza appears i get sent back to main menu.

i don’t get a message or anything so i’m a bit confused as to why i cant connect.

Many Thanks

Don’t know why the issue happens, but if you try joining enough times, you should eventually get in.

I’ve tried over 20x to no avail

I’m sure that’s something that used to happen to people who were banned from a server. Have you tried any unofficial servers to see if you can join them?

i can join unofficial fine, why would i be banned? and surely they would have notified me if i was, you cant just ban users and not tell them.

This is not related to any ban. If you were banned, it would show a message saying you are banned, not time out.

From what you are describing, it sounds more likely that you are running an older version of Tower Unite. Have you tried verifying your game cache?

1 Like

i shall try that now.

I’ve verified my game cache but the issue is still persisting. I’m on tower unite ( Build 1763987 if that helps.
i have uninstalled the game and reinstalled it but the issue is still persisting.

What’s your ISP? Do you have any firewall that could be blocking connection to the official servers?

virgin media and no, it was working perfectly fine a week or so ago.

What servers in specific are you trying to load into?

Frankfurt1/2/3 are the ones i use most but i cant load into any official server.

hey so i tried again today and i still cant get on, the same issue is happening where i will get to the plaza loading screen then it will just cut back to the home menu.

This problem is now happening to me…

Can you please specify the server?

It just says “loading”, then after like 10 minutes of loading, it finally, for half a second, says “loading Plaza”. But then just instantly goes to “Loading Main” then it comes to the Main Menu.

Every/any server.

It worked just fine like a week ago.

Please make one post per message, don’t make multiple with small notes.

In regards to the issue, I have rebooted the specific servers that were having trouble.

HI, so i think I’ve finally narrowed the issue down to my account as I’ve used the game on of my other steam accounts and it loads in perfectly, i have tried both accounts on 5 different computers in different places (work, home, mates house, computer shop and lan party) all of them came back with the same result, my account i’m having issues with didn’t load in, however my other account did. please could you check my account to make sure i’m not banned or something like that as i cant see any other reason why i wouldn’t be able to get into the servers. also if i am banned or server banned please could you explain why, yet again my other account using the same pc and game (shared across accounts) logs in just fine.

many thanks