Can't join servers from game worlds server list

Ever since the SDNL update, I haven’t been able to join in progress games of any type from the main menu’s game world screen, only the start a new game button works. Clicking on any game in progress in the server list makes the clicking noise and does nothing. Has anybody else been having this issue? What should I do? I’ve tried refreshing the list, relaunching the game, I’m on the latest version, I can’t find a work around. Is my only option to reinstall and hope for the best?

Edit: Forgot to include specs, hopefully it helps let me know if you need more specific ones ^^

Operating System
Windows 10 Home 64-bit
Intel Core i5 3450 @ 3.10GHz 67 °C
Ivy Bridge 22nm Technology
16.0GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)
Dell Inc.
DELL E1912H (1366x768@60Hz)
4095MB NVIDIA GeForce GTX 1650 (Gigabyte) 58 °C
476GB Lexar 512GB SSD ATA Device (SATA (SSD)) 29 °C
Optical Drives
High Definition Audio Device

After fiddling with stuff for a long while, I found out it’s because I have my hud size set slightly larger and the green join button gets hidden at some sizes. Problem solved but that’s a pretty annoying issue lol hopefully this helps somebody or makes the devs aware :+1:

1 Like

Thank you for figuring this out. I’m looking into what we can do with the UI to avoid this on higher scales.

1 Like