Can't join any servers

Hello, I updated my Windows 10 install from 1803 to 1909 and I can no longer join any TU servers. This includes any plaza servers, and mini game servers that anyone is hosting. It will just show ‘connecting to server’ then finally time out.

I have no issues join any server in any other game, no other changes have been made to my network topology or config.

Anyone else have this issue, or know of a way that I can debug this issue? I tried watching the open connections that the tower.exe opens up when I try to join a server and when I click join, nothing seems to even attempt a connection. My next step is to use WireShark to monitor network flow.

Other things I tried include: Resetting my modem/router and also connecting to a VPN to check if maybe my IP is being blocked by DreamHost (Who seems to be hosting TU servers). Disabling windows firewall, and the firewall on my router.

I have not tried a different PC, or rolling back windows updates… but since this is the ONLY game I cannot join servers on, I think its an issue with the game itself and there is no developer console or any useful logs that this game generates to debug.

I was able to fix the issue!

I tested the game on my Wifes computer and it worked! I re-installed the latest Intel drivers for my network adapter [Intel® Ethernet Connection I219-V] then boom! I can join all the servers now