Alt tabbing crashes the game when not on main menu

system specs - https://puu.sh/DxyCE/dcdf0bb136.png

game settings - top half, bottom half

this also locks up my task manager for about 3 minutes, so i can’t easily restart after doing so

i have tried every solution online, from adjusting the display mode from fullscreen, fullscreen borderless, and windowed, with windowed only having about a 50% chance of doing this. i have also tried booting into directX10 and X11 modes to see if there’s any difference, none other than a minor fps boost.

this does seem to be a problem with other unreal engine games i’ve played, but the solution in those is to use borderless windowed/windowed fullscreen, which doesn’t work in tower unite for whatever reason.
on another unreal game, i brought up the same issue and they seemed to have found a link between it and the audio thread, but this is very much speculation as their update which supposedly fixes it hasn’t been tested on the affected machines.

important to note that this only happens in game worlds, lobbys, and rarely condos, the main menu of the game is unaffected.

for reference, here’s a few threads of other people experiencing the exact same or nearly the same issue;



i am posting this thread to see if anyone else is dealing with the same issue and how they may have dealt with it. also to see if a fix to this problem can be found.
if i find anything that solves the problem i’ll update this post or add a response.

1 Like

I have had this issue for years. I feel it especially effects me during Virus but that may just be my head. Either way this is a huge problem and really needs fixing.

may have found a temporary solution; ESC before alt tabbing when in windowed fullscreen. i have also enabled v-sync which may have fixed it? not sure.
only one of the 8 times i alt tabbed with this method did it crash, and that one time it did was a short freeze that actually fixed itself.

it’s not a perfect solution, but it seems to work? will edit this post if the problem happens again.

(edit as of 9th june) - this solution does not work. just got the crash and lockup again with these settings on the first ESC then alt tab of the day while in the lobby.

1 Like

Yeah, last night, my computer went to screensaver—yeah, I still use that; don’t judge me lol—while I was in my condo, and the game crashed when I jiggled the mouse again. Something about losing D3D access? (I know that’s the graphics API.)

found a way to get past the system lockup, right click the taskbar icon and relaunch the game through there, tower unite will automatically kill the previous process without needing task manager.
this is a lot better than waiting 3-5 minutes for task manager to start responding, but it’s still not a suitable fix for the problem.

also, this information may be useful for finding out what’s causing the problem? i know this helps some developers in troubleshooting;

updating this thread to say that moving the game onto an SSD did not resolve the problem, but it has reduced the frequency of the issue massively.
however, after doing that, it does seem like the crash is temporary and eventually resolves itself; this never happened when the game was on a HDD.
because of this, i believe that the cause of this is something to do with game files unloading when you alt tab and then trying to load back in when you tab back in.

edit - going to end this thread here unless anyone else has a solution or i find one that works reliably. here’s what i found that helps it for any future visitors;

  • launch in DirectX10 mode, this reduces the chances of a crash significantly.
  • put the game on an SSD or try the PAK beta; loading with an SSD has seemingly decreased the crashes, have yet to test the PAK system.
  • if the game does crash and/or freeze, right click the taskbar icon and click “tower”, this causes the game to automatically kill the previous process. the tower that launches will not be connected to steam so you’ll have to relaunch once again. only do this if task manager does not respond, as using task manager here is infinitely better whenever possible.
  • always press ESC before alt-tabbing, this seems to reduce the crash chance slightly? unsure about this though.
  • there’s a slight chance that the crash is only temporary after alt tabbing. have not been able to reliably replicate this.