[] E Key Functions, Changing Appearance, Chat Issue

When you press E to play games in the Arcade (Plaza server), I can’t play them, despite the fact I can press E to enter the Arcade and that works, and I can buy tokens with E, but when I press E to try to play the arcade games, it doesn’t do anything even when i have the tokens. That’s Issue #1.

Issue #2: I can change appearance in main menu and SOMETIMES changes my avatar in-game in the plaza, but sometimes doesn’t. But, it won’t let me change my appearance in-game at all, not even let me remove my current avatar from the workshop, and not letting me wear another one in-game either. HOWEVER, it works in the condo and matchmaking, and the main menu.

Issues #3: When I type in chat (in the Plaza in a server), nothing I type comes up, as if I typed nothing when I press Enter, so I can’t chat at all. It DOES work in matchmaking though with the games.

My internet is fine, good speed, I’m on Windows 10 Pro 64-bit, GPU is Nvidia GeForce RTX 3060, CPU is Ryzen 5 5600x 6-core, 16 GB RAM, DirectX 12, Origin PC, if any other info is needed let me know.


Damn, multiple issues! Also, I’m totally not jealous of your PC… Okay, I am.

1 Like

It’s been almost a week…i really hope this isn’t one of those threads i’ve seen get passed for a month.

1 Like

Even after the Phase 2 update these are STILL issues for me and no idea why they’re happening to me but not other people? Help? This is extremely frustrating. And still no reply.

I managed to finally get in contact with staff on the Discord Server, you’ve got a better chance of getting a response there, we all tried a lot of things but ultimately the problems couldn’t be isolated…all I can say is, I guess the programming code does not like Origin PC computers. :frowning: well, at least i can still play matchmaking and do stuff with my condo.