Unable to upload to workshop

As of yesterday (or so I noticed), uploading to the workshop isn’t working for me. My intention is to just update an old condo, however, I tested uploading a “new” submission and it was broken as well.

I get to the final confirmation to Agree & Publish and get met with the following mess after attempting to proceed:

On subsequent attempts to retry, sometimes a failure message would instantly print before any sort of processing/uploading would be able to occur.

When I attempt to upload a snapshot as something new, rather than an update to an existing submission, it gets forever stuck on this and I have to close the game:

While writing this post, I decided to try uploading an item through the editor, rather than a map, and the behavior was similar, endlessly stuck on this:

Through all of this, there is no record of new uploads or updates in the version history of my items.

Based on a recent upload, I know this was working as late as Oct 20 @ 1:20pm.

So far I’ve:

  • Verified cache
  • Confirmed network connection
  • Used different maps, with & without canvases
  • Tried different filenames for the condo, without & without certain types of characters
  • Confirmed that local versions are being made before being uploaded
  • Waited a day

I have a fairly sizable collection of workshop uploads, but I’ve seen people with significantly more than myself, so I’m hoping this isn’t some weird Steam cloud storage limitation thing.

Steam ID:

1 Like

If your Steam Cloud size is filled, it’ll have issues uploading to workshop as the workshop upload goes to the cloud first (which is very silly to me). I have been meaning to bump up the file size limits so let me do that and you can try again.

Okay, I increased it. Try uploading now.

1 Like

No luck. Everything behaving exactly the same at the moment.

Also found that I don’t think i was near the limit before, since I had backed up a lot of my saved locally a few weeks ago?

What size is your image file? The Workshop upload was failing for me last night when my image was over 1mb.

I assume that would be this number?

Edit: reminder, this seems to be affect all the workshop for me, not just condos, I found.

My issue was specifically with a player model. But I seem to remember having this issue before and it had an odd solution? One thing to try, go to your Workshop and see if the game is uploading empty privated files.
I had this issue some time ago and that was a side effect of the failed uploads. I’ll look for what the solution was.

Additional things that haven’t worked so far:

  • Reinstalling the entire game
  • Signing out and logging back into Steam
  • Deleting a “Test slot” workshop item that had 100+ versions in it’s history
  • Various orders of turning cloud synchronization settings OFF & ON, both with TU and Steam itself, and restarting steam & my PC
  • Significantly reducing number of TU items on my personal Steam Cloud
  • Getting rid of what somehow accumulated to 125MB of Disco Elysium saves from the cloud
  • Checked if I’m still agreeing to the Steam Workshop agreement

Whenever I save a new condo snapshot, it does seem to synchronize onto the cloud, though.



I’m convinced Steam is fucked up, and i hold my breath for Tuesday maintenance.

1 Like

Waiting for Tuesday to roll around for a chance that Steam will start working like it’s supposed to do again? What am I, the Halloween event?


Thanks for the help everyone, but I guess it fixed itself after a few days :upside_down_face: