Touchscreen controls

So I have a Microsoft surface. I can run the game on it with no issues. Or so I thought. On Tuesday, when I was playing on my surface, I came back to the lobby to see two virtual joysticks on the screen. I tried using them, and was able to move my character with the left and move the camera with the right I could still use the keyboard and mouse to move and look. I didn’t think much of it and just quit the game to go to bed. But today joined a minigolf game and who was there? The two joysticks. Whatever, they’re only a distraction right? Well it turns out I was quite wrong. The controls didn’t let me click. i tried my mouse, I tried my touchpad, I even tried the touchscreen, but I couldn’t hit the ball. I wa able to pause and disconnect though.

Also I’m not sure if it will help, but I couldn’t fire my confetti gun in the lobby either. I was able to use my inventory and use the menu fine, but the confetti gun didn’t work. there was no virtual gamepad up this time though.

Seems like they have some features activated that shouldn’t be there. I’m pretty sure the devs never thought about supporting touch screen controls. Maybe the devs could deactivate touch screen support entirely:
Here you go @macdguy: https://docs.unrealengine.com/latest/INT/Gameplay/Input/#touchinterface

If you do not want any virtual joysticks, just clear the Default Touch Interface property. Additionally, you can force the touch interface for your game independent of the platform it is running by checking Always Show Touch Interface (or by running the PC game with -faketouches).

1 Like