Texture quality is constantly low due to my low VRAM

I only have 2GB of VRAM on my computer so no matter what quality settings I choose for my textures, they’re always shown in the lowest quality possible.

The last time I played this game, which was roughly a year ago, the textures were fine but just recently I’ve replayed the game and all the textures are way too blurry.

Picture isn’t mine, but this is exactly what it looks like for me constantly:

If you don’t care about going over the VRAM budget, you can add the launch option -notexturestreaming in the properties for Tower Unite in Steam to prevent it from switching to lower quality textures.

1 Like

Also, if your VRAM is that low, you may want to disable workshop playermodels entirely.

I’ve already tried doing that and it does work, but in return it makes the game run worse and I can’t even do certain things like use the machines at the casino.

Out of curiosity, what happens if you set your texture quality to high? That’s supposed to fit within 2GB, which is what Ultra used to be maxed out as.

Not sure if this will help with your problem, but you could maybe try switching the contents of the scalability config file to what it was before the recent update that changed it. If you go to %localappdata%\Tower\Saved\Config\WindowsNoEditor and edit/create a file named Scalability.ini and paste the following into it, I believe it’ll use the previous setup for uhh graphics stuff. If this doesn’t help, just delete the file and it’ll go back to using the default.





I have no idea why -notexturestreaming would break casino machines though. The running worse part of that will be because your GPU doesn’t have enough memory to store the stuff it needs so it has to take a second to load it off disk, which could cause a bit of a stutter I assume based on your disk/CPU speed.

1 Like

Well I tried doing this, and to no surprise, it did nothing. And when I set the texture quality to high it still looks like shit.

What does the game do when it doesn’t let you do casino? Does it kick you off the machines, or can you not even interact with them in the first place? Also does this affect arcade/trivia/typing derby/bowling?

It shows the message that displays when you don’t do the keypress in time (doesn’t even pop up) and it immediately takes me back to the place where you spawn into the plaza, with my character reset. I’m not too sure if the same happens with anything else though since I haven’t tried it yet but I’m gonna assume the same happens.

And it only happens with texture streaming disabled? You can play fine without the launch option? (aside from blurry textures obviously)

Yep that’s right.

This was due to a bug that the devs stomped out pretty recently, and it’s most likely unrelated.

Not to discredit your problem, but unfortunately a lot can (and has) changed from a year ago to now, a lot more content was added. Strangely, though, there was an optimization update as well which should’ve reduced issues like this. Have you tried using DX10 over 11 (if you haven’t yet), and also what’s your specific GPU model?

I did try using DX10 once and it didn’t really make a difference. And here’s my specs:

Device name DESKTOP-0IPSOO4
Processor AMD Ryzen 7 2700 Eight-Core Processor 3.20 GHz
Installed RAM 16.0 GB
Device ID 6992A617-DD73-4090-8DC7-F9ED9BA29AF4
Product ID 00325-96475-46224-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

This doesn’t list the GPU model, mind sharing that too? Things like Task Manager can tell you what it is.

My GPU model is Radeon™ RX 550

I’m not gonna lie, supposedly this card performs worse than a GTX 750 Ti, which I have used while playing tower before (while my 2060 was being RMAd) and that was barely able to hold around 50-60fps on Dx10. If you’ve tried -notexturestreaming and didn’t get any results from setting any of the graphic settings to low (and turning off workshop playermodels) then I don’t think there’s much that can be done. It’s an aging piece of hardware at this point, and one that was specifically designed to be entry level for it’s release time.

Well it turns out the game AFK booting off the casino machines was just a bug and they patched it out so doing the -notexturestreaming trick actually did work with very minor problems.

1 Like