[SOLVED] Corrupt Files, "Disk Write Error", and more| Game unplayable after update!

I just updated my game for the new update. When it was done downloading, it said it was unable to run because the files were corrupted…
If I try to run the game, it says the message again about my files being corrupt.
What do I do to play again?? :fearful:

Right click on the game > Properties > Local files > Verify Integrity of Game Cache. If this doesn’t work, try reinstalling. If that still doesn’t work, then I’m not sure.

I decided to reinstall, but when it was done downloading and when I tried launching, it gave me a error (disk write error). I redownloaded it 3 time now and am still getting the same message, making the game unplayable. I may need to get support from a developer like @MacDGuy :disappointed:

Could you head to steam/logs, open content_log.txt, and find any sections in the log that contain the disk write error message? That might help us zero down to an individual file where your install went wrong.

@Matt Im currently looking at all the text right now, but I confused about what Im trying to look for. Could you help me out? :sweat_smile: If you want, I could take a screenshot and send you it.

In notepad, scroll to the top of the txt, Ctrl+F, and search Disk write failure.

Alternatively, just copy the entire thing into pastebin and i’ll take a look.

It looks like it’s not being caused by a specific file in the depot, so it seems that it’s an issue on your end. Are you only having this issue with TU?

Since yesterday, my internet has been slow for some reason. I didn’t think that that would be the cause since TU only started having this issue when I relaunched and updated my game. After it was finished downloading, it said it was corrupted. I reinstalled the game 3 times and keep getting a error, which makes the game currently unplayable for me.
Do you know anything I can do? :open_mouth:

When you reinstall the game, absolutely make sure no files exist in the steamapps/common/tower unite directory.

So I delete everything in the Tower Unite folder? Ill try that. :blush:

@Matt It won’t let me delete _CommonRedist or Tower. It says it was being used in another program. What do I do?

Do you have administrative rights on your computer? That might be the issue of why you’re having disk write errors as well.

Im pretty sure, this never happened to me before. Just in. case, how can I change that?

To delete _CommonRedist + Tower, run file explorer as administrator. When installing Tower again, see if running Steam as administrator helps.

How do I open file explorer in administrator?

Actually, just try running steam as an administrator and seeing if deleting the files in there will get rid of everything.

@Matt Ok, I went ahead and deleted the local content as a administrator. I tell you what happens when it is done downloading. :wink:

If Windows thinks those files are currently being used, you could also try opening task manager.
To open Task Manage, press CTRL+ALT+DEL and select Task Manager.
Then open the Processes Tab (If you are on Win8 or higher, it should just be a “More Details” button at the bottom.
If you don’t see Tower running in the Apps section, try looking under the Background Processes. If you do find it, select it and then press the End Task button.
Maybe you should also try deleting the files while Steam is completely closed.

Otherwise, try resetting your computer and then try deleting the files from there.

@Matt I did what you said, and it still is happening. :frowning:
@Cold_finger Ill look into that!