My model is missing textures and its head

After many failed attempts to even preview my model in the workshop uploader, I finally managed to get it to work… kinda…

Just to clarify I used the Tower Unite Blender Tools addon of this very forum for both rigging and exporting… My model uploads with missing textures every single time, and without a head, I did work the head separately and then added it to the model (and I joined it all together), so everything is a single model as seen here:

…However, this is how it show ups

(with a weird texture like a tail, and the armature doesn’t have a bone tail so i dont know what happened there)

Haven’t done a spectacular job at rigging this new skeleton (yet)… since I initially used the “old” tower unite bones and I was just happy to see it show up finally in game… and I’m way more concerned about the missing textures and head

This is the model in DAE format if anyone want to take a look of whats wrong with it:

Any help is greatly appreciated

Any vertices not weighted to any bone will get moved to the origin (the area of the model between the feet), as can be seen with the stretching near the feet. It’s likely that the head’s also missing weights, which is why it’s not visible.


Thanks for your help! I’m not really savvy about weighting bones and such, with the armature provided by the blender addon I didn’t have to use “automatic weights” at all to get the results above, just plastered onto the model, but for some reason that don’t even work properly anymore…

I tried two things, first, just use “automatic weights” for the whole skeleton just to be 100% sure that the head was missing weights as you said, and yes, essentially that was the problem, but the model appeared as a nightmare on screen, then I looked up more info and realised that I had two “heads” in the model (as well as neck and others), one was the collar of the jacket and the other one was weighted just fine, so I paint-weight the collar one and got the exact same result as the “automatic weight the whole thing”, head appears, but still nightmareish, like this:

So… I have no idea how to identify the non-weighted vertex that you mentioned. Is there a way to do it? or just get rid of it? everytime I save the model I get a similar result. I also noticed that after I saved the file to .dae (the exact same one I uploaded in the post above) and open it up again in blender its when the vertex appears between the feet

1 Like