Model Vertice problem

Hi there, I’ve recently been having problems uploading a model in the workshop editor. The model only has 16k vertices, but it jumps to over 40k in vertices for some reason. I’ve tried every possible method mentioned on how to fix this issue. I’ve tried the smooth shading method, removing multiple uv maps, changing the faces or edges to quad, removing doubles, the works. Nothing sadly seems to work. I haven’t really had this problem before, but for some reason it’s doing this. Any help would be appreciated.

Here’s screenshots for reference:

Uv Map

Vertices in blender
Vertices in Blender

Vertices in Tower Unite

Changed to Quad
Vertices in Tower Unite after changing the Edges or faces to quad.

Not sure if this would be anything of an issue or not but if there was an error with vertices wouldn’t it pop up on the errors instead of it saying errors none?

If more screenshots are needed I’ll happily provide.

Might not be applicable in your situation, but UV seams are also counted as double. You could try removing doubles in the UV editor, but if you’re dealing with models with messy UVs (like 3d scans), you probably won’t be able to fix it without redoing the UVs entirely and baking the textures.