Model successfully uploads, but doesn't work at all and is apparently 0.000B

I’m trying to upload a playermodel via workshop, but every time I try it seems to be in a weird bugged state. It stays at 0.000B on the workshop page that’s generated, doesnt get shown on the tower unite workshop, and also doesnt seem to appear on my activity feed. Loading it from the in game “my uploads” page just loads forever. Also half the time I try to upload it I get “generic steam error” and I hit retry until it works. Is this something i’m doing wrong or should I keep deleting the workshop item and reuploading it until it works? It looks and works 100% fine in the workshop preview in game until I attempt to upload it

I originally posted this in the steam community threads but realized it would probably be better to post here since the people here are likely more experienced with the game and there’s better screenshot support. Some finer details:
-Used the tower unite blender plugin to generate armature and pose
-Model isn’t mine but has been uploaded to several other games fine
-Had to custom weight paint a few sections and merge objects together but otherwise didn’t modify anything
-Model works 100% fine in the metadata/upload viewer other than looking a bit jank due to weird proportions
-Uploading via in-game prompt so the metadata saves
-Tried waiting 24h to see if it just took time to process or something and it stayed exactly the same while other player models were added to the workshop in the time that passed

Here’s the workshop link and some screenshots



i’m not smart enough to help but i hope somebody else is. because i need that playermodel

I have found the issue for this, and hope that anyone else that experiences something similar finds this post and saves themselves a lot of headache

I tried to reupload over and over to no avail, eventually almost giving up and thinking the model was cursed, turns out it’s a wider problem with how steam family sharing works. I googled “generic steam error” because that’s the error I was getting before uploading successfully, and found this thread which ended by the person saying “oh oops I was logged into the wrong account”. I only have one account so that wouldn’t have been my problem, but I was sharing tower unite from my sister’s account via steam family sharing and was wondering if that was the issue. I’ve played this game for over 100 hours so even though we use a family account for all our games I figured I wouldn’t mind buying it again, and tried it after and it worked 100% perfectly first try. Moral of the story is if you get this error try seeing if you’re sharing the game from another library or if steam doesn’t flag you as owning it.

1 Like

I want to add that this error can happen regardless of family share status. Steam could have just failed the upload in the moment you tried to do it, which can happen for many reasons. Glad you got it working though!