Loss of all units (roughly 600k now shows as 0)

I don’t know if this is a general bug or isolated to me, but currently in game, I have zero units.

I had roughly 600k and haven’t played for a couple of weeks and came back today to find I have no units even though I have not spent any…

Is this a general bug? Or is this a bug that is only happening to me?

I’ve tried verifying the game cache but it is currently showing as zero in the main menu as well as in game

Payouts from minigames have also not been increasing the number of units and still shows as 0.

Thank you for any insight.

Rest assured, your units are still being counted, this is simply a display issue.

We’ll look into it.


Thanks very much for the response Caboose, its greatly appreciated.

Also have you tried checking your TU stats with the Steam API, and see if that one shows 0 Units?

Do it here: http://api.steampowered.com/ISteamUserStats/GetUserStatsForGame/v0002/?appid=394690&key=[yourapikey]&steamid=[yoursteamid64]