GMTower Launcher download?

My friend is having problems with downloading the workshop items for GMT, it just doens’t download and we don’t know how to fix it. The only think I tought was downloading it by the Launcher GMT have(had) but I couldn’t find it at the Download’s page.
It’s gone or I didn’t found it?

(Sorry if bad english, i’m from Brazil)

The launcher, I believe, has been deprecated. The only way to download the items is through Workshop. You have to wait for Steam to download them then open Garry’s Mod and download them, which will automatically start.

Just to double-check, go here and click “Subscribe All.”

1 Like

Oh, too bad :c

He downloaded all addons from the workshop, but the game doesn’t “read” it, I think only 6 addons worked in-game, the rest didn’t even installed.

Is the issue that Gmod wont “see” the downloaded addons? If they’re all downloaded you might be able to copy them from wherever they were downloaded to and move them to the “Addons” folder (Granted, I’ve only done that in L4D2, but I would assume it works the same way in GMod)

The thing is that I think they download but they don’t install, in that way they ARE downloaded but not installed, but i’ll see if that works, thanks <3

1 Like

No Problem, It’s worth a try, Like I said I’ve never tried it with GMod, but in theory it should work

This is why we’re happily leaving GMod.

There’s no solutions to the workshop download issues.


I completely understand. GMod is hell in a form of a game.

Also, after Dark Souls lll, Tower Unite is the game I am more excited about this year, I always loved Gmod Tower, I donated for it and I don’t regret it at all. When I first saw Tower Unite last year I was hyped as hell, and now that I know the things it will be added, I can’t wait for it.
Thanks mac and all you guys behind GMod Tower and Tower Unite <3

1 Like

That didn’t work, but thanks for the help. c:

If you have the addons yourself, you might want to think about zipping them up and sending it to him manually.

They’re in steamapps\common\GarrysMod\garrysmod\addons

Just search for GMA files with GMod Tower in the name.

It’s 5GB, though.

A friend told me that this woudn’t work, but i’ll try that, thanks.

It should work fine. I do it when I move to other computers.

1 Like

I can do that. I’ve got decent internet and a MEGA account.

1 Like

I would LOVE that! <3
Thank you so much!

I’ll be so happy if you do it, seriously. My internet have just 1mb upload, it would take forever. Here in Brazil is hard to get a good internet

I’m working on it. I’ll post again when the upload is complete, but it might not be til tomorrow (EST).

No problem. Thank you again <3

Did your friend “Enable All” addons at the gmod main menu? Ik when I got my new PC, I was having this issue, & came to mind that some of them were not even enabled & I had to click the “Enable All” at the gmod menu for it to work.

Here’s a MEGA link:


Thank you SO much! I’ll post here if it works.

There is no addon on the list, he can’t even enable them,