CopyCat & Undo Bug Megathread

I’m unable to use the Copycat tool in someone else’s condo even with permissions, but I’m perfectly able to use it in my own.

Using the Copycat tool in someone else’s condo:

Using the Copycat tool in my own condo:

TU version: 0.16.3.1

1 Like

0.16.4.0

Minor bug, but if you duplicate a Condo IO item that’s normally invisible (unless you have the Q menu/Tower Glove equipped) with the CopyCat and, while still keeping the Tower Glove out, open and close the Q menu, any Condo IO items you’ve duplicated with the CopyCat after equipping the Tower Glove will turn invisible. They’ll still be visible when holding Q, but won’t be visible with just the Tower Glove equipped until you unequip and reequip it.

1 Like

[0.16.4.0]

When duping canvas walls some properties are not saved to the original object, I get this with teleporters too which can be annoying

properties such as: World texture align, teleport prompt and canvas type

Notes and media:

https://streamable.com/d8x3xu

1 Like

Hi friends, I’m having a big issue with my condo save and I have no clue how to fix it. If anyone has any ideas I would greatly appreciate your help.

Context:

I was building on my custom island in the Courtyard villa condo. At this point, I have spent around 60 hours building on this condo.
I created a buoy from canvas materials and finished the object by grouping them together and alt+dragging them into the ocean to put them in their desired position. One item was lacking in the placed buoys so I used F1 to undo the placement and this is when things went south. Suddenly I and my friends cannot move any objects and all collision of every placed item is gone. There is no way to right-click any object and placing an object from the inventory will allow me to move it after placing it for about only half a second. I can’t interact with the teleporter I placed to get to my island at spawn. Sadly the latest snapshot is more than 8 hours prior to this version.

Upon troubleshooting me and my friend have tried the following things:

  • Saving a new snapshot, loading a different one, and reloading the snapshot created after the bug appeared.
  • Restarting game
  • Restarting PC
  • Try a previous snapshot many hours before the bug appeared (This snapshot was free of issues)

I will add to this message upon trying more troubleshooting, but several theories are occupying our minds right now:

  • The condo snapshot is corrupt
  • There is a giant item covering ALL of the map which appeared because of some error when undoing steps with F1

This is really bumming me out and I was hoping someone has more ideas for troubleshooting or ideally fixing this bug.
Please let me know if you have any ideas.

Doggo,

Anyone besides the host is unable to use certain CopyCat features within the condos regardless of permissions.

When building in my condo, others who are given permissions are unable to use the CopyCat tool’s duping feature as well as the rotation/scale copy and paste feature, though copying textures and pasting them to other items still appears to work. Other tools such as the stasher and the scaler still work completely normal for those who are having the issues. They are still able to use the CopyCat tool within their own condos, but once they join into my condo they are unable to use the duplication feature. For me, the host, the CopyCat tool works flawlessly.

We have loaded a previous snapshot of the world to see if the snapshot had been corrupted, and the issue continued across numerous snapshots. We joined another friend’s condo to test if the issue continued outside my condos and it did, the new host was able to use the CopyCat tool but no one else was, even when granted all server permissions. We have all also verified the integrity of the game cache for our games. This is a consistent bug that is repeated every time my condo is loaded or another is joined.

I stashed an item in a group and it ended up deleting the entire group. I undid this but the group wouldn’t come back.

1 Like

0.16.11.0

  • Undo option only works about 50% of the time when it comes to changing item coordinates and scaling values. I cannot figure out what causes the option to work or not. Sometimes it works, sometimes it doesn’t. Its really inconsistent and I mostly avoid using it to undo number changes.

  • Even when undo does work, it often requires several presses to activate once.

  • Undoing some objects can sometimes modify them in strange ways. I noticed when I undid a coordinate change, it reset the color of the object to default. In many situations, it straight up deletes the modified item. In others, it’ll reset its scale.

Its also pretty difficult to tell what you’re undoing. Having an undo list that shows each line would make things easier to keep track of.

1 Like

Similar to @Woah’s issue with Canvas Walls, but this is with a Non-Canvas item, so I thought I better report it anyway just in case:

Version [0.17.0.1]

Duplicating an item (Simple Lightbulb in the test) with Alt + Arrow Drag and CopyCat Tool results in the original being wiped of its properties.

Steps to Reproduce

Duplicate an item using Alt + Arrow Drag or the CopyCat tool.

What I expected to happen

Duplicate with the same properties being created, original retaining properties it had.

What happened

Duplicate is created with the correct properties but the original item being wiped to default.

Not really a bug but when you duplicate and move the selection you actually are moving the original pre duped selection. You would think that when you dupe a selection or an item you would want to move the duped selection or item instead. Could be a bug or a function that needs to be added in the code. I realized this when building I have a named item that I dupe but I still move that named item. Also the duped item does not have a name and is not selected. Hope this helps!

2 Likes

Hey! Thanks for replying, what you said is correct however for this post I was more confused on why the properties were not copied as well. Notice how the item is supposed to be pink string with yellow? The dupe turns up completely wiped of everything. This bug still happens to me every so often but I haven’t worked out how to reproduce it consistently… Weird.

There’s just certain items that are bugged and don’t copy their properties to dupes or other items. The only ones I remember right now are the Simple Lightbulb (the one in your screenshot) and all of the Ladder items.

3 Likes

Ahhh is that it… That makes a LOT more sense.

I can confirm this is still happening. I have a diner I’ve been working on; duplicated the named lamps and moved them; turns out that I actually moved the original items; leaving the new duplicated item behind. Threw me off for a bit. lol I personally prefer it that if you duplicate and slide them away; original named objects should stay where they are.

There is also a bug where the copycat tool wont copy custom names set for an object

That is by design, but it could copy the name and append a number after it.

Copying rotation and/or scale from one workshop item to another causes the item with the copied properties to shrink and become unselectable without box selecting or using the item finder.

Both workshop items have to be the same type for this to happen (ex. if the original item and the one you’re copying to are both Furniture, the bug will happen; if one is Furniture and the other is Physics, it won’t happen).

If you change the affected item’s rotation or scale it’ll fix itself.

1 Like