Condo Reset Issue? Need assistance

I know this is alittle “off-topic” but it was stated that since PixalTail Games have been working on Tower Unite, they did not keep their eye on the condo glitch. It happened to me a few months ago, and I have been very stressed about it. You can find out more here:

P.S. need assistance!

To quote on one of the Tower Unite threads on the old forum

Although we’ve been busy with Tower Unite, we haven’t forgotten about the issues that persist on GMTower.

We have a condo reset request form users can fill out:

This is the best option you can do about that.

I did that more than 4 times. Nothing ever happened every time tried. Kinda frustrated. :confused:

You submitted a form 5 times? Did you at least wait for them to reset it before submitting another?

Yes, I waited 3 to 5+ days between each other.

I’ll look into the issue.

Thank you so much.

@macdguy Sry if it seems Im rushing you, but have you figured this issue out yet? I have been saving up gmc for furniture, but I can not buy anything until this is solved. :slight_smile: (I remade the topic here)