Can't start TU using Steam/Proton. Begins running in background for a fraction of a second, then closes without visible window or error message

Hi. I recently migrated to Linux (Xubuntu 18.04.3 LTS) from Windows 10. Tower’s one of my favourite games to play with friends, and I’ve been trying without luck to get it up and running on my new OS. This is perplexing and frustrating as most of the reports on ProtonDB suggest people have been able to get it up and running out-of-the-box without any major issues.

I was wondering if anyone here had initially had the same issue and managed to fix it, or is willing to help me start to troubleshoot this (I haven’t been able to figure out if the game has left a crash log or where I might find such a thing). Any help, including just a place to start, would be much appreciated.

For me it has been working without doing anything, so this might be a pain to debug since I can’t test anything. But i’ll list a few things you can do with Proton maybe you’ll have some luck.

First i’d try opting into/out of the Steambeta client, which is what I’m using, perhaps Steam have done something that might have changed since regular release. I’ve actually had moments when Tower didn’t run and then switching beta/release worked.

Otherwise theres;

You can get a proton log by putting PROTON_LOG=1 %command% as the launch option in Steam. The logs will be in the Tower Unite game directory named: Tower-Win64-Shipping_dxgi.log and Tower-Win64-Shipping_d3d11.log <-- If you use dx11 option.

In case it’s useful to compare your own, I put my logs to pastebin but I’m not confident they’ll show anything useful, but who knows.

If you want to report a crash log(hopefully they’re generated for you), maybe they can uncover what you might need, i’d let the developers know in that post that it’s Proton related.
Crash dumps are located here;
/steamapps/compatdata/394690/pfx/drive_c/users/steamuser/Local Settings/Application Data/Tower/Saved/Crashes/

You can also set Tower Unite to use different Proton versions, on Steams Tower Properties you can select it to force use a different version, perhaps will get different results. For me personally I haven’t seen much difference between them as they all work. I do know however the latest 4.11-2 version is choppy, so I use 4.2-9.

If you want to access protons winecfg settings, you can do with the terminal command;
WINEPREFIX=/home/$USER/.steam/steam/steamapps/compatdata/394690/pfx/ winecfg
Just double check the directory is the same.
You’ll need winecfg, but you have to be careful what you edit there, changing smaller settings is fine, you can always revert them, I wouldn’t mess with library overrides, especially since the default settings work for me and others I don’t believe the settings should matter, but it’s an option you can look into.

I can only imagine as extra steps is to make sure drivers are up-to-date and your PC is restarted after that, if you have any major updates like Kernel / driver related things, make sure you restart afterwards because games likely won’t run,. I’ve had the very problem of getting an update then games not doing anything.

I want to help more but I don’t know what to suggest, I’ve played on Ubuntu 14.04 and now 18.04, with multiple Kernel versions and every time it has just worked.

Currently on Ubuntu with KDE Plasma 5, kernel 5.2.5-050205-generic, Nvidia 430.40.
HW: Intel i5 9600k, GTX 1060.

1 Like

No one can help without system information (gpu? cpu? cores? architecture? ram? vram? steam version? proton version?) and logs.

Mattio has explained how to do logging.

Please report logs and the problem to steam.

https://github.com/ValveSoftware/Proton/issues?utf8=✓&q=is%3Aissue+394690+ NEW issue, be sure to follow issue reporting format

1 Like

So, I did manage to solve this problem, weirdly enough by one of the things I attempted before making this post. Figured I’d put it here for the benefit of anyone with the same issue looking for a solution.

It turns out Tower Unite doesn’t like being launched on Linux from a NTFS hard drive. I recently switched to Linux from Windows, so the hard drive I keep my games on was formatted as NTFS. What fixed my problem was moving the game from that drive onto my main Linux filesystem.

For whatever reason this didn’t fix anything when I first tried it a couple weeks ago, but after giving it another go, the game now runs perfectly. Ultimately I reformatted my NTFS hard drive as Ext4 and moved the game back onto that. No issues at all so far.

Thanks to the people who replied to give advice and such. :slight_smile:

2 Likes