[0.5.1.0] Unable to use any "weapon" in the Plaza or Condos


#1

This is a bug that have been occured since month now and that is still persistant throught the updates and method to make it work again.

The problem is simple : any gun or weapon meant to be used by my character by holding it and shooting/throwing it once placed in the weapon hot bar(confetti gun, bubble gun, throwing knife, ect…) end to never appear in his hand despite the item being placed in one of the 8 emplacements, even when pressing the associated button afterwards.

This is happening of course everywhere where “weapons” are allowed, such as the Plaza on the outside or my every own Condo.
I already tried to uninstall/install the game, let steam verify the integrity of the game cache, removing/replace the weapon in his slot of course, and also erasing the whole content of the Steam\steamapps\common\Tower Unite\Tower\ClientPlayerData2 file while having steam cloud disabled so it could reset everything, but nothing works, my character still refuse to hold anything.

However, items that goes in the wearable hotbar perfectly works, jet pack as pets.


#2

That’s weird, I recommend filing a bug report


#3

Does the emplacement get highlighted after you press the correct button? If not, have you tried rebinding the buttons to something else?


#4

So I did bind my 1st weapon slot to M and… my character directly popped out his confetti gun.
Switched my second slot to W and I can make appear the gun without problem.

So I went back to the setting and… I think I get from where the problem was.
Rather then showing the normal command the button does ("&" for the 1st hot bar button, “é” for the second one, ect…) the settings menu simply show me an 1 2 3 4 5 related to the slot of the same number. This isn’t even linked to the numerical keypad, since the numerical show a “Num” before each number in the settings.

So I don’t get it, does the game have as default input non-existing buttons ?


#5

I don’t get it either, even though I’ve been having the exact same problem.
I’d recommend you try switching to an english keyboard layout, as that does fix the issue for me. However, it also switches the positions of some letters (blame czech keyboards for getting it wrong), so I generally use mouse 4 and T for bringing out and hiding a single equipped weapon.


#6

There’s your problem. The default settings are designed for a standard English-language QWERTY keyboard. The 1 2 3 4 5 you’re referring to is the number bar at the top of the keyboard, which apparently yours lacks (yours apparently has symbols instead). Just rebind the keys to that hotbar you refer to and it should work.

Pic of QWERTY keyboard for reference:

EDIT: Just figured out that you have an AZERTY keyboard. That’s why its not working. Like I said, this game is designed with QWERTY in mind for the default bindings.


#7

Okay, I was dumb and assumed OP has the exact same problem as me. In my case (QWERTZ), those top row buttons can’t be binded to and any attempt at it results in the selected key showing up as “None” in the settings. You’re right, if he can rebind the keys properly, he should.


#8

According to Wikipedia, on an AZERTY keyboard, you need to hold shift to type a number. That’s his problem.


#9

With an AZERTY keyboard, can you rebind the keys?


#10

Yeah, I know. I was just trying to explain why I recommended switching to an english layout in the first place. My keyboard (with a layout that’s pretty similiar to the standard CZ QWERTZ layout, although it has some differences) requires you to hold shift to get the numbers as well (unless you switch to an english layout, which is shown on the physical keys alongside the czech one), but the game doesn’t allow binding to characters that you get when you don’t hold it. I assumed it was the same on OP’s end without giving it much thought.


#11

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.