[0.17.12.0] Workshop models will not load, deleting cache loads it but it breaks after

Trying to select a Workshop model gives me an infinitely loading armature, deleting the Workshop cache fixes it but then joining a game breaks it again and other people’s models don’t even load and it doesn’t even attempt to try to load them sometimes.

I’ve tried a lot of things: restarting the game, restarting my computer, restarting steam, nothing has worked.

2 Likes

Having the same issue here, I just uploaded a model, loads in just fine the first time, but after i join again it infinitely loads and never seems to work again until I clear cache, but then it happens again anyways.

Can you try:

  • Right click on Tower Unite in your Steam Library
  • Manage > Browse Local Files
  • Navigate into Tower/
  • Delete ClientPlayerData2 folder.
  • Restart your game.

Does that resolve it?

From debugging it with another user please check this setting:

Settings > Content
image

Make sure workshop mods and player models are enabled.

The issue became a bit better on its own but doing this, once everything loaded in, I’m not running into any issues at all, so thanks. Can’t speak for everyone but as of right now I’m not running into any Workshop issues.

And yeah, my Workshop mods were enabled the whole time.

1 Like

Unfortunately this solution only works for a limited time for me, even after the hotfix, it works just fine for a bit but after that I just see people with their model permanently loading.
And yes I have everything that’s workshop enabled. Any other leads that could be the cause?

I’ve been noticing workshop models (both items and playermodels) haven’t been loading properly sometimes after latest update (not the hotfixes, but the main update). I’ve had it happen twice now where nothing will load but restarting the game fixes the issue. Until it happens again.

I’ve also noticed that for some reason when trying to load workshop models the loading bar at the bottom for them will hang and instead of finishing the download the bar will disappear. I wonder if it’s failing and stopping loading on models all together?

1 Like

Also, yeah, unfortunately broke for me again. Not a big deal though, the fix is easy to apply and lasts a while.

Edit: Just tried the fix and it didn’t work this time.

This file is handled by the steam cloud. You have to delete it while the game is running, and it’s not being accessed (e.g. at the main menu (NOT in the appearance menu)) otherwise steam cloud will restore it to the previously bugged state.

@Herobrine @OctopusSandwich Are you talking about deleting ClientPlayerData2?
Can you instead try toggling the setting off and back on again as mentioned by Mac here:

And let me know if that works? We’ve noticed an issue where that setting is actually different from what is shown for some polayers (which is another issue we’ll need to fix), and it’s somehow gotten toggled off despite it showing it’s on. Thanks!

I’ve been trying all the potential fixes in this thread, and so far nothing has worked. Only some models are having this issue, one of which is one I had just commissioned a rig for. It had been working for about 2 weeks after its upload, but ever since that update I have been unable to load it. Other models uploaded by the person I commissioned still work. One of my friends is able to see the model, despite it showing as endlessly loading to myself and my other friends.
Also yesterday a friend had an issue where a Kakyoin model that showed up fine for two people in my friend group, showed up as the “loading” avatar but with a sand texture. It seems like there is a lot going on right now and I’m looking forward to a fix.

1 Like

Is this model unlisted?

Nope. It’s the Bedman model uploaded by kokidoki.

It doesn’t work any different than usual. Works and then breaks again over time.

This time it only took about 5 minutes before trying to switch Workshop models again caused endless loading and then after that none of them worked at all.

I am having the same issue a model I uploaded like a year ago works fine 100% of the time, but a newer one I just uploaded has this issue, only working once when I clear cache and restart the game. Oddly yesterday I was having the same issue with a friend where they just uploaded a model and I could not load theirs and once that happened it seems I could not download anyone’s models anymore even people who should of been in cache.

4 Likes

Wanted to add on that I am still experiencing the same issue as of the Erruption update. Arguably it’s worse as now, even when I select a player model that ‘works’ on the main menu, the second I go into a game I have the default player model. I tried deleting the workshop cache and it seemingly worsened things, as now a friend’s model as well is showing as the blue armature for me.

Try dequipping your workshop model, set a different default model, then requip the workshop model.

My model and my friends that was having issues like 3 days ago just started to behave, I am not sure if it was due to them being too newly updated or something but it seems fine now

1 Like

Experiencing this issue too, for me specific workshop items (player models, furniture, sounds etc.) work when I load into one map but get caught in an endless loading loop after leaving and loading into another. Clearing cache and restarting the game fixes it for one map but it breaks after that. Some models work and some do not, and I’m not sure why.

this model works for one map load and breaks afterward.

This model seems to work consistently.

Nevermind. Suddenly the scientist model works like expected. No clue what’s going on here.

I’ve got this issue as well. It’s with these two models:

A temporary fix I found is deleting the models in the Workshop tab in the game’s properties menu, although the same issue pops up when loading the plaza or another condo. I’ve also tried what was mentioned here; clearing the cache in both Tower Unite and in Steam, as well as deleting the ClientPlayerData2 folder. I also tried reuploading one of the models with no luck. The creator of the models said that he had no issues with the mods, although a friend of mine was able to replicate the problem I’m having, so I’m wondering if it’s something client-side. I’ve tried running the game under Windows 10 and Linux Mint 21.3 with the same issue.

EDIT: Much like PepperRoni, the models started working on both installs this morning without problems. I didn’t do anything overnight and there haven’t been any in-game updates so I’m very confused as to why it’s decided to start working.