[] Condo: Sound Emitter Playback Issues

I have ran into a few recurring bugs with the new Sound Emitter (which could be a carryovers from the Spooky Sound Emitter). The first bug I have ran into is when placing an emitter and selecting (Lava, Ethereal, Cave or Dungeon) they will work as intended until you exit and host your condo again, they will then not be playing anything unless you edit the sound emitter and reselect the same sound.

Steps to Reproduce

Place an emitter, select Ethereal, Lava, Cave or Dungeon. Save condo, Re-host your condo (bug still reproduced on hosting public, private and solo) The sound emitter will not be giving off any sound until edited.

What I expected to happen

For the Lava, Ethereal and Dungeon sound effects to play as intended.


I have a theory that maybe having too many of the same sound effects (even when separated by distance) might cause them to start breaking? Is there a limit? This happened when I tried placing many Ethereal sound effects in my condo it started breaking all Ethereal sound effects across the map. Yet other sounds worked just fine.

Edit: This seems to be happening for the Host only, just tested with a friend and he can still hear them when I cannot before editing them.


Still happens on

I’ve seen it happening with Cave Heavy, Room Tone, and Room Tone Scary

Yes, I have noticed the Cave sound effect is breaking as well. Just tested on latest update (as of this post Still seems to be an issue.

1 Like