[] Condo room-cast shadows not appearing on specific lights/condos

A lot of condo light-casted shadows aren’t appearing for me, but they seem to work normally for everyone else. None of my room lights with shadow casting on work at my House condo, only a couple work at my Condo condo, but all Highrise room lights cast after recently buying it. But no room lights cast shadows in my friend’s Highrise.

This was all checked with the option enabled in lights, personal settings, and seeing it side-by-side with a friend’s screen and my own. I’ve tried reinstalling the game, deleting Tower’s appdata folder, and deleting Unreal Engine folders found in appdata. I’ve also changed the game’s install location for an unrelated reason and that had no affect on it. Placeable light objects however do cast shadows.

Steps to Reproduce

I just open the game, open my House condo, and enable shadow casting on lights unless they’re already enabled. Same for Highrise, I just load in and they work properly, on mine at least. Loading into a friend’s Highrise acts as my House, shadows just dont appear for lights besides the ones coming from outside.

What I expected to happen

I expected room lights to cast shadows for objects and player models when the option was enabled from the Edit menu.

What happened

No objects or player models cast shadows from room lights with the option turned on.

Notes / Media

Standing under a light in House

Proof of the setting being enabled

Shadows being cast properly in Highrise

And not sure if possibly related somehow, but keybinds will not save on exit. I’m mainly looking to get this sorted before I open another topic for that issue.