[] Condo update feature not working

My underwater condo, as well as other condos I own, will no longer update to the Steam Workshop. It’s stuck on a version that was updated April 23 of this year.

Steps to Reproduce

Unsure if it can be reproduced by others. I simply click Update Existing from within the condo and fill out the update information, changelog, etc.

What I expected to happen

The condo would update, and the Steam workshop page would show the newest version.

What happened

The “update successful” popup would appear, but the Steam workshop page would not change to a new version. Even waiting until the next day did not work, nor did attempting to update the starter condo. Sometimes the “upload successful” popup doesn’t even appear and the game just crashes.

Notes / Media

Successful update popup.

Steam workshop page showing outdated condo version, last updated April 23.

Steam workshop page showing duplicate screenshot preview images. It seems the update is only being partially processed.

Condo workshop page: Steam Workshop::[WIP] okesska plaza 420

Given you posted this on Tuesday, it’s likely that you just got caught up in the weekly Steam maintenance. Try uploading it again.

1 Like

I’ve tried updating it a few times in the past month or so and it still doesn’t work. It’s really strange and I haven’t figured out how to fix it yet.