[0.16.0.1] NPCs T-posing, missing workshop model in Condo

Basically, I have a few NPCs in my condo which, every time I join, are T-posing and missing their workshop model, using a default one instead. Can fix by removing and re-adding workshop model but that is a bit of a hassle every time I join my condo. Oddly enough, some NPCs that have been in my condo much longer work just fine. It’s the same NPCs every time.

Steps to Reproduce

None really, happens every time I join.

What I expected to happen

NPCs load in, in the correct pose, with the correct model.

What happened

Instead they appear as pics


Notes / Media

Attached




1 Like

I believe this bug was fixed in the recent update, but you’ll have to stash and re-place any affected NPCs.

I’ll give that a try thanks

Just tried this and no dice. Thank you anyway :slight_smile:

I also have this problem, done full reinstalls of both steam and tower. I have tried most things in game from just moving the npc to changing the model(Doing this makes the npc go invisible for me).

Yep it sucks. From what I can gather, visitors to my condo can see them just fine. Just me with the issue

Yeah i can confirm this. Everything is fine except NPC which are fine for everyone else. it only seems to happen with 2+ NPC,s are on the condo at once. Seemed fine with just 1.

Same issue here.

All 10 of my NPC’s are T Posing females. Been having this issue on and off since at least a year back.

Hopefully it can get permanently fixed soon.