[] Textures Randomly Drop in Quality in Condo

A bug I’ve been experiencing a lot recently when decorating in my condo is that textures will randomly drop in quality at some point. When loading in the condo, they appear correctly, but at some point after everything has loaded in, the quality drops.

Sometimes after a while, the quality will go back to normal, but more often than not, it doesn’t. I’ve also tried disconnecting and re-opening my condo, which doesn’t seem to fix anything as I experience the same series of events again.

  • Picture 1: before everything has loaded in
  • Picture 2: after ( ~3 minutes after ) everything has loaded in

Note the difference in quality of the floor texture in both pictures. I know that neither my internet nor my hardware are causing this.

iirc this is because the game/engine can get kinda funky with how much VRAM it thinks it needs compared to how much is available, which can cause this to happen. This is something that has been reported in the past and can be alleviated by using the launch option -notexturestreaming to force the game to use the highest quality textures possible at all times. May see a performance dip or increase in VRAM usage, but it should fix this issue.

Just in case you don’t know how to do that, right click the game in Steam and go to “Properties…” and then type that into the “LAUNCH OPTIONS” section.

Pictures if needed



this worked, thanks so much!

just out of curiosity, howt do the other phrases you have in those screenshots affect the game?

-nosplash makes it so the little Tower Unite window that pops up before the main game loads doesn’t appear, which I just have in there because it makes opening the game a bit quicker, which was a lot more useful a year or two ago when there were crashes around every corner. Still makes it nice to just get in quicker though.

This is the splash screen:

-useallavailablecores is supposed to force the game to use all available cores on your CPU, however the devs have said in the past that this is the default functionality and using this launch command probably doesn’t do anything. I have it in there just in case it maybe does do something, though I don’t have the energy to actually test it or not.

-noini doesn’t seem to work on game clients, only servers, I just forgot to remove it. From what I understand it’s supposed to prevent the server from updating the ini files, so I was hoping it’d work in the client as I’d like my Input.ini file (the one that saves your key bindings) to remain the same after restarting, even if I change them in game. This mainly comes up with Avalanche as I change my jump button for that, but because I normally have both space bar and scroll wheel bound to jump I have to manually go into the file every time and reset those as you can only bind one key to an action from the menu, which usually results in me going into the local appdata folder and moving a copy of the file into the Config folder.

1 Like