[0.10.1.0] Accelerate's controls act up when using Switch Pro, and controller type is forced into XBox One

So I use a Switch Pro Controller with Steam, and I recently I upgraded my computer to a new motherboard and CPU, and everything else seemed to work fine until I went into Accelerate and my controls would either be unresponsive and my control stick’s input would stay stuck in one direction and/or not turn, causing me to go off track and not have much control of the game.

I later found out that despite me setting my controller type in Tower Unite’s settings to “Switch” prior to my upgrade, the controller type reverted to “Xbox One”, which I assume was the cause of what happened. Even after setting it back, it would still force it once I left the options screen, and it still happened even if I unplugged my controller.

I can confirm that there’s nothing wrong my controller as it operates fine in a different game and my Nintendo Switch itself.

If it will aid with any help, my specs are:

  • Mobo: MSI B450 GAMING PLUS MAX, 32GB RAM
  • CPU: AMD Ryzen 5 3600
  • GPU: MSI GeForce GTX 1660 SUPER

Any help would be much appreciated.

EDIT: I can confirm this seems to be the issue with a Switch Pro only right now, as I tried a different controller with an adapter to use XBox 360 controls, and it worked fine.

1 Like

When you select switch controller select another setting to it maybe doesn’t save also maybe the switch one is not working with the pro controller only with the joycons or the otherway but since you are on a pro controller maybe it’s that, is it a nintendo official one or a third party?

I’m using the official Nintendo one, which Steam should natively support. I even have it set to the proper settings in big picture and it works fine in other games like Slap City and Rivals of Aether. Tower is the only game I seem to have issues with it right now.

Have you changed the settings in game?

That’s what I’ve been doing, yeah.

EDIT: I’ve decided to grab videos of my issue. They are still present in the latest patch of the game.

Controller Type being forced:


Controls acting up in Accelerate:

You can clearly see my kart go right even though I’m holding left at the 7 second mark in this one. Also, pardon the GC input display being used, gamepad viewer does not have a switch skin for some reason.

Now I see it resets it doesn’t save did you try changing another setting?

Don’t think I have. What other setting could I change?

Just change something you don’t worry about maybe it saves then

Tried that. Controller type is still forced into XBox One