[0.1.4.0] Condo Textures don't stay loaded when Condo is filled with items

So not sure if this is related to this issue shown here: [0.1.4.0] Texture bugs in and around new Tower area

But when i go to my condo and edit stuff, it’s annoying because all i see is textures constantly loading and unloading, and some textures won’t ever load properly. From what i’ve found it seems to only happen to condos with alot of items in it and textures will stop glitching out once you reset it. It also seems to happen to both the person who is hosting the condo and the people who are connected as my friends pointed out the textures doing the same thing for them at the same time.

Please note the gif above isn’t repeating. It’s actually doing that loading and unloading. You can see this in more detail in these videos:

1 Like

This happens when you run out of VRAM.
Currently, if you have really large canvas images, it will make the problem worse.

1 Like

But i have a brand new MSI GTX 1070 Gaming X 8GB. How could i run out of vRAM? The game barely uses 2GB

This also happens on EVERY SINGLE TEXTURE, not just canvases. Here’s the texture glitch on a rock & boxes

At the moment Unreal 4 only uses 2GB VRAM no matter your hardware. Until we add a setting, that is.

Once it hits 2GB, it will stream out textures to make the most of the texture scene.

By canvases, I mean if you have a lot of canvases, or a couple with really large images, it will use up your VRAM and effect texture streaming on all textures, not just themselves.

Is there any way around this, say add a Launch Option in Steam or something? Because this unloading and reloading of textures is driving me crazy. I do have alot of Canvases in my condo (most of which do have images loaded) and it would be a pain to have to pick all of those up temporarily until you guys add in a VRAM slider.

I may have just figured out how to increase the Texture Pool myself.

I went to %localappdata%\Tower\Saved\Config\WindowsNoEditor and edited Engine.ini and added the following lines:

[/Script/Engine.RendererSettings]
r.Streaming.PoolSize=5120

&

i also added

r.Streaming.PoolSize=5120 to the Launch options, but i’m almost fairly certain this does nothing as the ini edit seems to have done the job.

It seems to have worked as my textures are staying loaded and the game seems to be using over the 2048 (or whatever integer it’s set to near 2GB of vRAM) amount of vRAM that is allocated. Since my card includes 8GB of vRAM, i gave myself some growing room as i’m fairly certain that i will be adding more stuff in my condo.

2 Likes

wont that vac ban you, editing game files

The game isn’t vac secured (and as far as i’m aware cannot be) and also, considering the devs themselves have had work arounds that edit these same game files, it doesn’t worry me about that. Plus, why would i ever want to do something that can harm a game that i love?

It is.

1 Like

That won’t really get you banned. He’d have to add heavily manipulative .dll or .exe files to the game or change the game files in a malicious way to get VAC’d. Editing .ini s which are basically just different cfgs, should be okay.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.