[] "Your connection to the host has been lost" on every official server

Hey there, I played yesterday around noon CEST just fine, today I’ve tried connecting to official Plaza servers (mainly Frankfurt ones, but also tried every other to check it wasn’t an isolated issue.

It seems to connect, switches over from the bigger “Loading” spinner to the smaller one pretty quick (within 5 seconds or so) and then maybe 30 seconds later it just kicks me back the the Error screen.

Community servers I can connect to without any issues.

Steps I’ve taken to try and resolve this on my own:

  • Turned on/off Windows Firewall
  • Reset my router (change IPs)
  • Verify game integrity on Steam
  • Rebooted Computer
  • Restarted Steam

Intel Core i5-2500 @ 4 x 3.7 GHz
16 GB of DDR3-1333 RAM
Gigabyte Windforce R9 380 4GB Edition (Driver 16.9.1 Crimson)
Windows 10 Pro Anniversary Update (Build 14393.187)

The servers do seem to have alot of issues atm. I’m sure @Caboose700 might be able to help though.