Unable to redeem. Unable to connect to Steam. - And other things


#1

I’m currently on version 0.7.0.2 and tried to log on today to complete the three Catsack- oriented achievements. Here’s what I found:

  • Shop NPCs still seem to be bugged since 0.7.0.0, locking you in the “Transaction in progress” screen until you leave the plaza, and shortly after I discovered that my items had been successfully purchased anyway.

  • Upon trying to redeem any units I had earned in the form of Piles, Bags, Chests, etc., they have simply been unable to be redeemed with the message “Unable to redeem. Unable to connect to Steam.” popping up each time I tried. I logged on and off multiple times, validated my files, still no change.

  • When I spawned into my Resort condo, I gained the “Moving On Up” achievement, but with no payout- I also obtained the “Space Race” achievement just to make sure it wasn’t lag, and still no payout. Combined with everything that occurred beforehand, I’m led to believe that achievements stopped paying out for this fix. I had these problems only once in a while when in 0.7.0.1, not guaranteed when I logged on now.

If it’s just something wrong on my side, I’d very much appreciate some assistance.


#2

Probably because it’s Tuesday and steams undergoing maintenance.


#3

Now online on Wednesday, issue is persisting.


#4

We’re working on the issues.