Tower wont let me play due to Visual c++ 2015 "not being installed"

Okay, I’ve been dealing with this problem for nearly a month now, and its pissing me off.
When this problem started is after I wiped my harddrive some time ago, due to it being slow and stuff. I wanted to play some Tower Unite, so I decided to go install it. When I tried to start it up, it gave me this error:
So I tried to fix it.
Every. Single. Thing. I have tried, doesnt work.
Reinstall C++ 2015? Done it, didnt work. Do it in a certain way? Didnt work.
I’ve done nearly every single thing, and this error plagues my game.
Ive even wiped my harddrive to try to get it to work again, EVEN THAT DIDNT WORK.
I installed windows 10 once to try to fix it, and it did, but Windows 10 bluescreens my PC into oblivion, so I reinstalled Windows 7.
Like I said, I’ve done EVERY. SINGLE. THING. and it wont work.
So, please, can a miracle worker or something come in here to help me? I really want to play Tower Unite, but this error makes it a paperweight in my steam inventory.

I’m trying to run the server version, and I cant even install C++ 2015.

If you just reinstalled Windows 7, you’re gonna need to install:


I get the same thing but on windows 8