Tower hasn't worked for a while

I am having a problem with Tower Unite, I stopped playing a while ago but REALLY want to play again. There is a problem, every time I try to start the game, it freezes on load and crashes, no error report or anything. I have downloaded and attempted to play the game on multiple systems all to the same result.
I have reinstalled the game, verified files and everything.

I think it may be an account thing???

Specs: (both unless stated)
1060 6GB
i7 970 (Desktop)/ i7 8700 (Laptop)
16 GB Ram

1 Like

If you think it might be an account thing, you could try buying something from Tower Express, which should automatically reorganize your inventory, and possibly solve some inventory-related issues.

If that doesn’t work, you might have some luck with the lowbandwidth branch of the game instead (Right-click “Tower Unite” in the Steam Library -> Properties -> Betas -> change dropdown from NONE to lowbandwidth)

You mentioned being able to play a while ago, and a recent update changed how the game files were formatted, so switching to lowbandwidth should restore that old behavior.

Thank you, I’ve already tried low bandwidth mode to no avail, and will try buying something from express once steam let’s me log in (entered Password wrong)

Tower express didn’t fix the issue either.

Okay you might want to do a clean uninstall, in the fallout modding community it is advised to delete everything manually as it would make sure some old files don’t cause problems, you could do the same with Tower by deleting everything Tower related.

Oh and check if you have Pak version enabled in steam properties

Could you please explain a little more about what files to delete and what PAK means?

I deleted the entire game manually and re-installed but it did the same.

If you go to your TU properties in one of the windows there is a option called Pak, what Pak does is compress the game into a single file for faster load times with the drawback of having to reinstall the whole game after an update.

Try turning it on or off after that then do a manual uninstall again, make sure there aren’t any left over files and go to view in file explorer and tick show hidden files so you can delete hidden files.

This is all I can do right now, if it still does not work message a dev about it.

Where is this properties menu, because I cant get to the main menu of the game?

Also, how could I contact a developer outside of hoping the see a forum post or something?

Thanks for all the help Nina And Carbon!

They are talking about the Steam properties for the game (right-click on Tower Unite in your Steam library), where in the “betas” tab you can switch between the default branch and the lowbandwidth branch of the game. However, PAK is enabled by default in the default branch, and I doubt that this has anything to do with the problem. But you could try switching to the lowbandwidth branch anyway, just to be sure.

In case that does not make a difference, could you take a look in your crashes folder inside the AppData folder ([Install drive]:\Users\[Windows username]\AppData\Local\Tower\Saved\Crashes)? You could also navigate there manually in Windows Explorer by executing %appdata% in the address bar, which brings you to ...\AppData\Roaming. In that folder, look for folders named something like UE4CC-Windows-... and see if such folders were created recently, when you last tried to launch the game. If so, please take the most recent folder, compress it into a .zip or .rar file or anything similar, and upload it to a file hosting service such as Dropbox or Mega.nz and share the link in a post here. That way we can look into the cause of the crash. We are sorry for the inconvenience.

Thank you for the reply, I have previously looked for crash dumps but never found any. But I will look in the recommended spot when I can.

My problem goes to any system I play on. Be it Desktop, Laptop or GeForce Now.

There are no crash dumps from recent times, and I have already tried lowbandwith.

Well, that’s puzzling…
Do you happen to have any other Unreal Engine 4 games that do work on your machines?

I have no more UE4 Games, I’m downloading one right now to test.

The Unreal Engine 4 game Sea Of Thieves runs fine, would you like me to try another UE4 game?

No, it’s fine, thank you. I just wanted to rule out the option of the UE4 engine causing launch problems overall.
I will discuss this with the other developers, because I personally do not know where to go from here…

Hmm, this is tricky so I’mma throw some questions at you to try to narrow things down.

You mention it freezes on load and crashes, do you mean loading into the main menu or like a plaza or something?

Also since you mentioned it affecting multiple machines I wanted to make sure there wasn’t any issues with your steam account as that’s the only thing that should really carry over between machines.

Are you running in offline mode? Are there any VAC issues/VAC bans with the account you’re using? I tried following the steam link in your profile but it 404’ed, is it up to date?

Thank you Madmijk and Sketchman for helping me with this.
To answer your questions, it crashes while loading to the main menu.
To be more specific, it crashes at the screen that mentions that the game may freeze while loading.
Even more specifically, it causes all my browsers to freak out and stop all the open pages, but I think that is because if fills ram to 99%.
Task manager also says Not Responding next to it when it freezes (may not be important, just giving you anything I have).
I am not in offline mode, and I have zero VAC bans for any game.
By the way, I don’t think I had my steam profile linked so I have gone ahead and done that now.
If there is still an error, here is a link to it https://steamcommunity.com/id/server_reset/.
If that does not work, my name is Server Reset and my profile photo has the letters S3 and servers in the background.

This is bizarre. If I were to take a guess I’d say that something is just running in a loop eating more resources until you run out of memory and crash but I have no idea why it would be doing that or where. Running on my machine it only uses about 600mb to get to the main menu.

Are there any other outlying factors you can think of that might be consistent across the machines you tested? Some setting, or perhaps you’re running on Linux/mac or something? This is a head scratcher.