Steam Launch Requires Microsoft Visual C++ 2015


I’m not sure if this forum is limited to the game bugs that happen inside the game itself, or just bugs in general.

The bug that is keeping me from playing the game at all (after waiting a tedious amount of 4 hours due to my poor internet speed which adds to the frustration of attempting a re-download to no avail) is a bug that claims the game requires Microsoft Visual C++ 2015 in order to play. I checked my programs list and sure enough, I have most of the packs from 2005/08/10/13/14/15.

For the past eon it seems, I’ve done my best with my knowledge to try and crack this one bug but I just can’t. Here’s some of the things I’ve tried to do to fix it:

  • I’ve done the basics such as setting myself as full administrator and going as far as disabling the UAC just in case it was an admin execution problem.
  • I tried deleting files that have caused past issues with ones that I needed to fix in order to try and fix these current Microsoft Visual C++ packs.
  • I’ve re downloaded the game itself as stated above.
  • I’ve also restarted Steam and verified the game cache as well. I’ve tried running all the files as administrator and the game itself.
  • I’ve tried giving myself complete ownership of all the files possible in order to prevent restrictions.
  • I’ve asked friends to send me what packs they have and they look identical to mine, and the 2 people I’ve asked have also sent me exact error reports when trying to install Microsoft Visual C++ 2015, yet one of them owns the game itself and can currently run it no problem.
  • I’ve tried everything that I know could possibly work, even going into safemode with internet to see if that would fix the more complex processes.

Other posts like this have not been solved and/or they’re from a long time ago and don’t go into nearly as much depth as this one, so I’m hoping for a response because 15$ may seem like cheap for most, but when you’re poor, you want to generally be efficient and frugal with your money. I spent money on this game just off of one person’s recommendation and it looks like an awesome utopian game I’d love to play, almost Sims-esque, but I can’t because of one obnoxious glitch in the matrix.

If anyone has a fix for this, please spill the beans. I’ve been losing my sanity for a straight 4 and a half hours now.

Have you made sure that Windows Update is turned on?

Jesus, that was fast.

Yes. I just logged off of my computer unfortunately because it’s 2:03 AM here and I’m pretty irritated to begin with.

I restarted all the Windows Services even remotely linked to the updates and installed new and optional updates and restarted around 5 times after that has been finished.

I also made sure to constantly check if they were set to automatic and also restarted again after manually setting them to automatic just to make sure there was no failure in the service boot ups for any reason. I also have the latest MS Frame Network as far as I know, in case that might be an issue. I’m all out of ideas currently.

Same problem

Are you on Windows 64-Bit?

Windows 7 Home Premium 64 BIT.

I’ve installed the 64 BIT MS packs as well as the 86 ones, and I’ve tried both of them at the same time and both of them seperately at different times; no difference.

Anyways, I got to get some shut eye or I’ll be miserable later on today. I can give more info when I get back onto my system. Thanks for the lightning fast replies though, I’m still very eager to play TU with my boyfriend. :slight_smile:

my friend has this same problem

Tried a couple other things since I just got done showering and eating and unfortunately I still can’t get it to work.

E: I’ll post back if I get it to fix and I’ll tell you the stuff I’ve done if it does happen to work.

Here are my basic computer specs.

If you need specific parts I can grab the names for you.

This is just a shot in the dark, but have you tried doing this?

(Credit to: Slushii) on the Steam Forums

I have also had this issue.

The way I solved it, was by uninstalling BOTH of the Microsoft Visual C++ 2013 Packs, as well as the Microsoft Visual C++ 2015 Pack.

Then I reinstalled the Microsoft Visual C++ 2013 (Both x64, and x86) as well as the Microsoft Visual C++ 2015 (x64) Pack.

Hope this helps!

Unfortunately, I uninstalled all of the MS Visual C++ packs from 2008 all the way to 2015 and have tried reinstalling them all multiple times and nothing has changed.

Now for me, what’s happening is there is now a hang on the install of the 2015 C++ packs. I installed 2013 perfectly fine but the 2015 C++ packs refuse to install. The 64 BIT pack will stall right at the end, and the 86 BIT pack simply refuses to install half way through and states that ‘Another installation is in process at the time’ when there is not, which is extremely odd and aggravating at the same time.

I’m losing my mind as I’ve been reading up on all possible MS Visual C++ 2015 pack errors that people have been having not only on Tower Unite but other games such as Starbound and a couple other I can’t remember from 2 AM this morning. These people stated the only fix for them was a clean install of their OS and all the required MS packs on a brand new HDD or clean external HDD, which I have neither of those, so I guess I’m royally screwed and left in the dark just like all other tech issues I have since they never work out with my fixes or other peoples’ fixes anyways.

Whenever you try re-installing one, do you do a restart each and every time?

I haven’t, I install them in bulk and then restart post-installing and patching if there is any. It seems all the packs prior to 2015 install perfectly fine and instantaneously, while the 2015 packs are the polar opposite.

I’m going to restart all services to make sure they aren’t being blocked on the Win Update centre.

Also, before I restart 4 times which will be a tedious process since this is a 3 year old rig without an SSD, can you explain if you want me to restart after installing each separate MS C++ pack, or after installing both the 64 & 86 BIT packs together, then restarting?

I would try restarting after installing each separate pack. In theory, this shouldn’t give you the “Another Installation is in progress” error.

Alright. I’ll be watching this post on my phone in the meantime after installing the packs. I’ll be a while probably. Only problem that’s worrying me is I checked the processes tab on Task Manager while I was installing and after installing (rather attempting to install) the packs and there was no Windows or MS processes that would remotely relate to the pack installations as far as my knowledge goes, which is what’s worrying me about this, but I’m desperate at this point for the smallest amount of light to shine through.

* Immediately starts praying to a higher power.

And that is when I realized there is no hope for me.

E: I don’t even know what that means.

delete system32. xD

I don’t know what I did, but I gave my computer about 2 hours to boot up properly since I went to go cry myself to sleep after giving up on life.

Exactly 2 hours later, I tried installing the 2015 packs again, and they installed with no problems what-so-ever.

I uninstalled the 2015 C++ packs, both of them, and left the 2013 C++ packs installed. I restarted and got that funky error, and then took my nap. I got up, tried installing the 86 BIT pack first, and it installed fine. Didn’t restart, did the 64 BIT pack perfectly fine. Now I can open TU. I’m going to pray that I don’t experience any more base file errors like this…

I couldn’t be happier now that I can enjoy a relaxing game for once with my boyfriend. Thanks so much for your help! :heartpulse:

1 Like

Glad it works. Have fun!