Purchased Grand piano, vanished from inventory

Spent 15k on buying a Grand piano, and tried to place it in my condo. I pulled it out to place it, didn’t like the positioning, so I pulled it back into my inventory to re-place it. Instead of going back into my inventory, the piano vanished completely and though it says I still own the item when I press ESC and check the inventory tab, I absolutely cannot see or place it down and play it in my condo.

Some help would be really appreciated; this is a very frustrating bug.


Please try to add some video evidence of this bug. This can be a video aswell as screenshots.


Maybe it’s lower in the inventory? Scroll all the way down in the Q tab. Another possibility is it placed somewhere odd. It might be on the ceiling.


There’s some screenshot evidence. You can see it’s nowhere to be found in the condo inventory, yet shows up in my other inventory menu.

Bump. Really not happy about being out 15k

Have you tried noclipping in your condo and looking around for it? It might be placed inside a wall or something.

Yeah, it’s nowhere to be found

You might be able to get it back with this method, but it’s more of a last resort sort of thing and will wipe your condo. (Also, I haven’t actually tested it yet.)

  1. Put all of your furniture in your inventory in case this doesn’t work (precautionary measure).
  2. Go to
steamapps/common/Tower Unite/Tower/SavedData/Condo.dat

back it up (precautionary measure, if you didn’t take out your items and the other steps don’t work, you can restore this and get your condo back), then delete it.
3. Verify game cache (maybe?) and then open up your condo.

If what I’m thinking is right, doing that should clear your condo, and since the piano no longer exists in your condo but is still in your Steam inventory, you should get it back in your in-game inventory.