Player Model

I am trying to import my own player model, I have finally sorted out the compiler errors I kept getting, now I get missing texture errors.

I created the model in blender, made sure I was below the maximum vertice allowance, I applied textures (tried both material and UV) before rigging to the workshop rig and then checked the textures again, exported as a .dae and selecting the relevant texture options.
Yet I can’t get the model into the game, it always says that I am previewing the model but the model doesn’t appear.

I have been making 3d models in blender since 2011 without any problems.

Can anybody suggest anything I may have missed or done wrong.

Did you apply rotation and scale to the model before exporting it?

I have managed to get some sort of player model in the game, lots of long spindly purple lines.
I’m guessing it’s a weighting issue, but I can’t seem to find where I am going wrong.
I removed all of the materials and tried again, still not getting any textures either.