No verification e-mail received

I tried registering on the Open Trivia DB site to try it out but sadly I haven’t gotten any e-mail from when I registered, so I can’t login. The e-mail address I used is the same one I used for the forums.

Also before anyone asks, yes I already checked the spam folder.

1 Like

I successfully received mine…
Strange you have this problem…

I didn’t get one either

1 Like

I’m not getting one either

1 Like

Site must be broken. People (like myself) are having issues with the setting of the questions ‘correct’ answer for true/false based questions too.

I’m sure Caboose will have it sorted soon.

I’m not getting mine either ;-; rip us

Count me in, too. Registered a couple hours ago and have yet to receive mine either.

I got mine totally fine. Maybe it takes a while or that it got sent to another place somewhere in your emails?

I’m with Gmail and mine arrived instantly.

I’m with Microsoft’s Email service and it didn’t arrive still

Hmm. I guess you’re just going to have to wait for Caboose to get online to sort it. I’m assuming the site as a whole is just having issues. :confused:

Checked every place, and it’s nowhere to be found. Used my old hotmail e-mail address, perhaps it doesn’t like hotmail domains for some reason?

Yep, I’m on Outlook as well.

This. Square Enix also has this problem with FFXIV accounts. Signing up with Outlook does not work, But signing up with Gmail does.

I made a second account with gmail and it worked fine.

I can confirm that Gmail worked flawlessly for me.

Yahoo Mail doesn’t work but I assume Gmail does

The thing is, I can’t register with another email because the username is already taken

valve pls fix

1 Like

Buy some more CSGO/TF2 keys and then we’ll talk. - Official Response from the man himself, Gaben.


can confurm
Using Outlook, verification email didn’t get sent.
Is it normal that GMail mostly works with things but Outlook doesn’t?

Apparently the host we use sucks with emails.

Have you tried doing a password reset (which will send another email, and assuming you get it, just reset your password and it’ll verify your account).

If that still doesn’t work, we’ll figure something out.

As for the question editing stuff, it’s fixed it just has to be pushed to the server.

1 Like