Linux Client



This card has no description.


“Caboose700” commented "A couple of days ago I started testing to see if I could compile Tower Unite for Ubuntu Linux and OpenGL. Lo and behold, it worked, and I now have a couple videos of Tower Unite successfully running on Ubuntu Linux. Keep in mind, that this client is nowhere near release, as there are some severe graphical issues which are easy to identify in the videos below. That being said, I did want to update you guys on this feature, as this is something we do want to get out to you in the future.

While I’ve stated that this is in no way an indication of any impending release date for the Linux Client, this is some great progress towards the cross platform release, and brings us that much closer to getting a client out to our Linux users.

This first video shows how the Linux Client performs with the Game Worlds. At the time of this video, we didn’t yet have a compiled dedicated server to test with.

This second video shows how the Linux Client performs with the Lobby Server.

Hope you enjoy our progress, and can’t wait to further update you in the future."


i think this is where we comment? idk

Anyway, Is there any chance of a cheeky build release? Just for some super preliminary testing.


I personally feel that it’s in a state where there could exist a beta branch for Linux Users, under the guise that there is no guarantee that it is in working order and isn’t the highest in the priority list. We’ll have to wait and see what happens however, and there is nothing I can say at this time if that will or will not happen.


Super excited to see progress. I would recommend hopping over to /r/linux_gaming if you reach a wall, as they’d be really excited to see this is making headway and would gladly offer help.

Really looking forward to see progress on the linux support. Would be awesome if we could see it released in Q1 2017.

Really looking forward to playing natively on Linux. It currently doesn’t work in WINE or VirtualBox because they have very limited support for Direct3D 10/11 and Tower Unite doesn’t support OpenGL. I did get it working in VMware with frustrating freezes every few seconds (i7 6700k, GTX 1060, 16GB DDR4, VM on SSD). Since I won’t be dual booting Windows and the glitchy Linux build appears much more playable than my experience with VMware, here’s my vote for a public beta branch. I won’t complain about the glitches, I promise. :slight_smile:

For what it’s worth, I tried making a Windows client with OpenGL to see how it would do in Wine, but how Windows does OpenGL is a bit shit so it was even worse that what I showed in the Linux videos.


[ul][li]“Caboose700” commented “We have released a public beta on Steam. Linux Public Beta”[/li][/ul]


[ul][li]“Caboose700” commented “In preliminary testing for, I’ve noticed that OpenGL 3 Mode (the default Graphics Rendering Mode) has issues with refraction on the window glass in the new Lobby One Condo and the House Condo. This will create some color artifacting. However, if your card supports OpenGL 4, you can set a launch option in Steam of “-opengl4” and this fixes the issue. OpenGL4 for the most part operates the same as OpenGL3, actually eliminating in some areas some of the big visual issues with particles (instead of them being giant glowing balls for example, now they are small black squares). The only degradation I noticed was the old water we use for Condo Pools, Lobby Pools, and some of the Minigolf Maps didn’t work with OpenGL4, and would default back to a default checkerboard texture.”[/li][/ul]


Hello! After a bit of testing, I think I’ve found a way to fix at least a few of the visual glitches present on the Linux client.
Based on my testing, this fixes the Midori Bloom, lowers the intensity of the technicolor lights, and fixes condo water.

Ensure that the following settings are set:

Effect Quality: High
Detail Mode: Ultra

Detail Mode will be set to “Medium” on every boot of the game, regardless of what it was set to before. You must set it back to “Ultra” before you enter any games, lobbies or condos; Setting it at any point after you have entered a game world, lobby, or condo will not work.

Didn’t work for me, still get the same colored bloom explosions with no noticeable difference in quantity or intensity in the Lobby. I know Vulkan is supported by my system, I have a GTX 1060 and Vulkan clearly works and behaves differently than OpenGL when I use it in The Talos Principle. If a forum search is any indication, it doesn’t look like TU has any support for Vulkan yet, so I suspect something else resolved the glitches for you. Before and after screenshots would help, so I know if I’m looking at the same glitches as you.

Okay. I’ve done more testing, and I think you’re right. I was able to fix all of the same issues with -opengl4, so I’m willing to bet that -vulkan genuinely isn’t doing anything but causing TU to default to opengl3, which would explain the condo water suddenly working again. My bad.

However, I still believe that setting Detail Quality to Ultra and Effects Quality to High fixes the bloom issues in Midori and Summit, as well as the transparency issues with most other effects. Bad news: It seems to be quite literially random if it works or not. About 50% of the time, I’d follow my own instructions and end up with the same bloom issues, and about 50% of the time, it’d work just as it did before. I’m seriously confused.

I took videos to show what I mean. In both these videos, I am using the exact same launch options (-opengl4), settings, and I take the exact same actions before going directly into Midori. The first time I tried it, however, the bloom was present. The second time, it was not. It really does seem to be about 50/50 odds on launch.

Here’s the video in which it didn’t work.
Take note of the actions I take in the main menu, and how, at the end of the level, the “FINISH” in the goal is rapidly switching between different colors and is not animating correctly.

I took this video, in which it did work, literially seconds after the first video. I didn’t change any settings, and I took the exact same actions.
And it worked! Loading into Midori works great; All of the lighting is correct, and the waterfall in the background even looks right, whereas in the first video, the transparency on the textures didn’t look right. The “FINISH” marker at the end stays one consistent color and animates correctly.

So there is an element of randomness to it, and you are correct; I was mistaken, and -vulkan does nothing. I really have no idea where to go from here, as I have no idea what random element is causing the fix to sometimes work and sometimes not, or if there’s something that can be done to make it work consistently.

I’m not sure what changes has been made or if any changes has been made, but when I played yesterday I was able to actually play for 2 hours without crashing! Water and some minor visual artifacts were broken and voice chat didn’t work, but it was still “playable”. Last time I played it took significantly longer to load the lobby and it crashed every now and then, so at least there’s some slight improvement.