Lights shining through opaque surfaces

Default condo.I places a giant slab on concrete on the roof to turn it into a floor so I can build a second story. If I’m downstairs and I open the sliding glass, I’m looking at the bottom of that concrete slab, which is the desired result on that front. I want to put lights on this new “ceiling”. Since there don’t seem to be remote-control lights I can turn on and off from that far away, I want to simply close the “glass” (which I have set as a ceiling texture) to block the light and open it when I want that light to illuminate the downstairs, allowing me to effectively switch between “normal” and “party” lighting mode by hiding or revealing what’s behind this sliding divider. The problem is that even when this slider is closed the light still shines through it as though it wasn’t there. Light light panel or spotlight (I tried both) is hidden, but the area below is still lit. How do I make this surface truly opaque?

Edit: I tried achieving the same end result by instead attaching the light to the sliding ceiling, but it appears that nothing actually anchors to that, as the light remains in place and hovers in the air when I retract this sliding ceiling.

Do you have your shadow settings on ultra? Anything lower the shadows and lights might shine through.


Thanks, Mac. For some reason it didn’t occur to think of walls as casting shadows. I kept thinking of the rooms as closed systems and comparing it to a leak in a map in Hammer or something. If there is an FAQ that covers this sorts of questions, I have failed to find it. I appreciate your and the community’s patience with my many questions the last several days.

1 Like

We have been updating our FAQs but there is a lot to cover. Stay tuned for a much larger FAQ after the break.

1 Like